summaryrefslogtreecommitdiff
path: root/app-admin/filebeat/filebeat-6.2.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/filebeat/filebeat-6.2.4.ebuild')
-rw-r--r--app-admin/filebeat/filebeat-6.2.4.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-admin/filebeat/filebeat-6.2.4.ebuild b/app-admin/filebeat/filebeat-6.2.4.ebuild
deleted file mode 100644
index cf379ba2e314..000000000000
--- a/app-admin/filebeat/filebeat-6.2.4.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eapi7-ver
-
-DESCRIPTION="Lightweight log shipper for Logstash and Elasticsearch"
-HOMEPAGE="https://www.elastic.co/products/beats"
-SRC_URI="https://github.com/elastic/beats/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="test"
-
-DEPEND=">=dev-lang/go-1.9.2"
-RDEPEND="!app-admin/filebeat-bin"
-
-S="${WORKDIR}/src/github.com/elastic/beats"
-
-src_unpack() {
- mkdir -p "${S%/*}" || die
- default
- mv beats-${PV} "${S}" || die
-}
-
-src_compile() {
- GOPATH="${WORKDIR}" emake -C "${S}/filebeat"
-}
-
-src_install() {
- keepdir /var/{lib,log}/${PN}
-
- fperms 0750 /var/{lib,log}/${PN}
-
- newconfd "${FILESDIR}/${PN}.confd" ${PN}
- newinitd "${FILESDIR}/${PN}.initd.1" ${PN}
-
- docinto examples
- dodoc ${PN}/{filebeat.yml,filebeat.reference.yml}
-
- dobin filebeat/filebeat
-}
-
-pkg_postinst() {
- if [[ -n "${REPLACING_VERSIONS}" ]]; then
- elog "Please read the migration guide at:"
- elog "https://www.elastic.co/guide/en/beats/libbeat/$(ver_cut 1-2)/upgrading.html"
- elog ""
- fi
-
- elog "Example configurations:"
- elog "${EROOT%/}/usr/share/doc/${PF}/examples"
-}