summaryrefslogtreecommitdiff
path: root/app-admin/durep
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/durep')
-rw-r--r--app-admin/durep/Manifest6
-rw-r--r--app-admin/durep/durep-0.9-r4.ebuild33
-rw-r--r--app-admin/durep/files/durep-0.9-dirhandle.patch31
-rw-r--r--app-admin/durep/files/durep-0.9-gigabyte.patch17
-rw-r--r--app-admin/durep/files/durep-0.9-r4-color-output.patch98
-rw-r--r--app-admin/durep/metadata.xml6
6 files changed, 191 insertions, 0 deletions
diff --git a/app-admin/durep/Manifest b/app-admin/durep/Manifest
new file mode 100644
index 000000000000..36f60e6542c2
--- /dev/null
+++ b/app-admin/durep/Manifest
@@ -0,0 +1,6 @@
+AUX durep-0.9-dirhandle.patch 848 BLAKE2B 71966b1b72740ecdd4178f93e09df9294039a59da088a00a93209d4ffc7f38f298791f71078afb420f145ceca50b98e429bb7db2a208e3218e703858d4669f72 SHA512 8e887393bab2c011cdf9ae096fc4f8b077c02c471203768c9f51b59df0a36f94aad797ffc017cf03ab0ddd2eed5e290d3ec65c90774bebacb5c35673ac3f176d
+AUX durep-0.9-gigabyte.patch 327 BLAKE2B 54838c927f77bb493489b4f63835f8c2e1b91f1d8bb3f77e5b8bc072617e04a27c82697e69879e0f8b650c5900deaa5ca3065ebab0b08f9bcb16988e550050cc SHA512 2bb28c5956cc6f8b301890f82eb86255f84ed6f93d1dc61e96bacb840ae0181feed76e992bca86249e9003701666784fdf7a40331c6c1731c55b3e3d2a4897b8
+AUX durep-0.9-r4-color-output.patch 3477 BLAKE2B 07bb50e252793664fd09d26e65abfddccf252259e712a7e239e8693ed4b0c03e6e308f899d38e2261d3204b7c06606978210393450376c7ba0e7fbf8f08f06ea SHA512 18bd766f706bf2036b1da35c0daf1add0adb6603a6cd0c68277efff8e1f2f8224cc2d79ca6c4afc70db9a01b5eec8a4ca7899c7c92b0bd38f709e7736731937a
+DIST durep-0.9.tar.gz 13713 BLAKE2B ac8cab90eeec1f9dcf1c5f6ba3043ee1de909cc288f3d1692d272b77c426932cb8b9c500fc7901c85a8eeeef3db4632b76c1ff5cf8a094c971867a3557052322 SHA512 a8a58cf4a77fa43e06eb22ce70e566fe9c5dd6921677dbe4691a6dd95e2fad3735778a9858e3b80957ba6efd20293fcd2ba4ddc9cfe29f5813997de0f9c96b6d
+EBUILD durep-0.9-r4.ebuild 746 BLAKE2B 78db882a49b4be171fdc1159adab160286f910e34e3e0b7051da43a1d615c2684ce36d8e620b8fd0a6d1ee43aa256e84d5cc07f20819c317a13d00e6f079ab2e SHA512 73458ffd706804959eddaabc0a06b879562e0855a4b75d47a8dcee0b1c24109740efede4d6c846192b6fe6b9ecea00306fe86abdf83261658f337da00b1fc138
+MISC metadata.xml 267 BLAKE2B 2496f74910a8e395abde0819a7f36ecc7fb7d10639cc3ddfbbf1645c5683c6352af932ec5538b19d4e21ddbd80cb5dc23a4a64f1618a7411129f33bf9dc54d81 SHA512 cbdeb6992e6acb977746b55685ae3d60dcf00915b48002a5e7eb47830207e7cad52ae212cd8831282274c454e45faa65422dcd5ac50185f429642fb34818609c
diff --git a/app-admin/durep/durep-0.9-r4.ebuild b/app-admin/durep/durep-0.9-r4.ebuild
new file mode 100644
index 000000000000..8a1b40e1159e
--- /dev/null
+++ b/app-admin/durep/durep-0.9-r4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="A perl script designed for monitoring disk usage in a more visual way than du"
+HOMEPAGE="https://gentoo.org"
+SRC_URI="http://www.hibernaculum.net/download/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-perl/MLDBM
+ virtual/perl-Getopt-Long
+ virtual/perl-Term-ANSIColor"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gigabyte.patch \
+ "${FILESDIR}"/${PF}-color-output.patch \
+ "${FILESDIR}"/${P}-dirhandle.patch
+}
+
+src_install() {
+ dobin durep
+ doman durep.1
+ dodoc BUGS CHANGES README THANKS
+ dohtml -A cgi *.cgi *.css *.png
+}
diff --git a/app-admin/durep/files/durep-0.9-dirhandle.patch b/app-admin/durep/files/durep-0.9-dirhandle.patch
new file mode 100644
index 000000000000..ee2930622370
--- /dev/null
+++ b/app-admin/durep/files/durep-0.9-dirhandle.patch
@@ -0,0 +1,31 @@
+--- durep 2007-09-08 11:44:05.000000000 -0500
++++ durep.new 2008-12-15 10:04:14.907825184 -0600
+@@ -175,6 +175,7 @@
+ my $coalesced_size = 0;
+ my $node = {};
+ my $temp;
++ my $dirhandle;
+
+ $node->{ID} = $next_id++;
+ if(defined $parent) {
+@@ -196,9 +197,9 @@
+
+ $node->{TYPE} &= $TYPE_COLLAPSED unless $store;
+
+- opendir(DIR, $dir) or warn "Unable to open dir '$dir': $!\n" and return $node;
++ opendir($dirhandle, $dir) or warn "Unable to open dir '$dir': $!\n" and return $node;
+
+- foreach(readdir(DIR)) {
++ foreach(readdir($dirhandle)) {
+ @stats = lstat "$dir/$_" or warn "Unable to lstat '$dir/$_': $!\n" and next;
+
+ $node->{MTIME} = $stats[9] if($_ eq ".");
+@@ -247,7 +248,7 @@
+ $file_count++;
+ $node->{FCOUNT}++;
+ }
+- closedir(DIR);
++ closedir($dirhandle);
+
+ if($coalesced_count) {
+ if($store) {
diff --git a/app-admin/durep/files/durep-0.9-gigabyte.patch b/app-admin/durep/files/durep-0.9-gigabyte.patch
new file mode 100644
index 000000000000..315cb1c7c813
--- /dev/null
+++ b/app-admin/durep/files/durep-0.9-gigabyte.patch
@@ -0,0 +1,17 @@
+fix `durep -hs 1g` output
+
+Patch by Stephen Tallowitz
+
+http://bugs.gentoo.org/108942
+
+--- durep
++++ durep
+@@ -468,7 +468,7 @@
+ elsif ($temp =~ m/^[mM]/) {
+ return $size * 1048576;
+ }
+- elsif ($temp =~ m/^[mM]/) {
++ elsif ($temp =~ m/^[gG]/) {
+ return $size * 1048576 * 1024;
+ }
+ return $size;
diff --git a/app-admin/durep/files/durep-0.9-r4-color-output.patch b/app-admin/durep/files/durep-0.9-r4-color-output.patch
new file mode 100644
index 000000000000..6b8956199406
--- /dev/null
+++ b/app-admin/durep/files/durep-0.9-r4-color-output.patch
@@ -0,0 +1,98 @@
+--- durep
++++ durep
+@@ -14,6 +14,8 @@
+ #############################################################################
+
+ use Getopt::Long;
++use feature 'switch';
++use Term::ANSIColor qw(:constants);
+ use File::Basename;
+ use MLDBM qw(DB_File Storable);
+ use Fcntl;
+@@ -27,6 +29,7 @@
+ our ($root_node, $filesystem_id, @stats);
+ our ($opt_help, $opt_version, $opt_textdepth, $opt_hidesize, $opt_showdate, $opt_nosort, $opt_quiet);
+ our ($opt_savefile, $opt_loadfile, $opt_desc, $opt_collate);
++our ($opt_nocolor);
+ our ($opt_files, $opt_onefilesystem, $opt_collapsepath, $opt_excludepath, $opt_coalescefiles);
+ our ($root_dir, $file_count, $dir_count, $next_id);
+ our ($TYPE_FILE, $TYPE_DIR, $TYPE_EMPTY, $TYPE_COALESCED, $TYPE_COLLAPSED);
+@@ -56,6 +59,8 @@
+ "d|desc=s" => \$opt_desc,
+ "c|collate=s" => \$opt_collate,
+
++ "nc|nocolor" => \$opt_nocolor,
++
+ "f|files" => \$opt_files,
+ "x|one-file-system" => \$opt_onefilesystem,
+ "cp|collapse-path=s" => \$opt_collapsepath,
+@@ -332,13 +337,58 @@
+ printf(" [%s%s] ", "#" x $numofchars, " " x (30-$numofchars));
+ printf("%6.2f%% ", $percent);
+ printf("%s ", shortDate($entry->{MTIME})) if $opt_showdate;
+- printf("%s%s\n", $entry->{NAME}, $entry->{TYPE} & $TYPE_DIR ? "/" : "");
++
++ printColor( $entry ) unless ( $opt_nocolor );
++ printNoColor( $entry ) if ( $opt_nocolor );
+ if($entry->{TYPE} & $TYPE_DIR) {
+ printDir($entry, $indent+1) if(!defined $opt_textdepth || ($opt_textdepth > $indent+1));
+ }
+ }
+ }
+
++sub printColor {
++ my $entry = shift;
++
++ my @tmp = split /\./, $entry->{NAME};
++
++ if ( $entry->{TYPE} & $TYPE_DIR ) {
++ print BLUE, BOLD, $entry->{NAME}."/\n", RESET
++ }
++ else {
++ given ($tmp[$#tmp]) {
++ #executable (bright green)
++ when([ qw(cmd exe com btm bat sh csh) ]) {
++ print BOLD, GREEN, $entry->{NAME}."\n", RESET
++ }
++ #archives / compressed (bright red)
++ when([ qw(tar tgz arj taz lzh zip z Z gz bz2 tbz2 tz deb rpm rar ace zoo cpio 7z rz) ]) {
++ print BOLD, RED, $entry->{NAME}."\n", RESET
++ }
++ #image formats
++ when([ qw(jpg jpeg gif bmp ppm tga xbm xpm tif tiff png mng xcf pcx mpg mpeg m2v avi mkv
++ ogm mp4 mp4v mov qt wmv asf rm rmvb flc fli gl dl) ]) {
++ print BOLD, MAGENTA, $entry->{NAME}."\n", RESET
++ }
++ #misc.
++ when([ qw(pdf ps txt patch diff log tex doc) ]) {
++ print GREEN, $entry->{NAME}."\n", RESET
++ }
++ when([ qw(mp3 wav mid midi au ogg flac aac) ]) {
++ print CYAN, $entry->{NAME}."\n", RESET
++ }
++ default {
++ print $entry->{NAME}."\n", RESET
++ }
++ }
++ }
++}
++
++sub printNoColor {
++ my $entry = shift;
++
++ printf("%s%s\n", $entry->{NAME}, $entry->{TYPE} & $TYPE_DIR ? "/" : "");
++}
++
+ sub processSizeOption {
+ my ($size, $temp);
+
+@@ -438,6 +488,9 @@
+ -d, --desc=<description> give description of save file
+ -c, --collate=<dir> collate save files in dir for web report
+
++Color Option:
++ -nc, --nocolor no color output
++ By default durep color outpu
+ Inclusion Options:
+ -f, --files do not descend into subdirs, only report files
+ -x, --one-file-system do not traverse file systems
diff --git a/app-admin/durep/metadata.xml b/app-admin/durep/metadata.xml
new file mode 100644
index 000000000000..a1d1cac5ab79
--- /dev/null
+++ b/app-admin/durep/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <longdescription>A perl script designed for monitoring disk usage. Similar to du</longdescription>
+</pkgmetadata>