summaryrefslogtreecommitdiff
path: root/app-admin/diradm
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/diradm')
-rw-r--r--app-admin/diradm/Manifest2
-rw-r--r--app-admin/diradm/diradm-2.9.7.1.ebuild39
2 files changed, 17 insertions, 24 deletions
diff --git a/app-admin/diradm/Manifest b/app-admin/diradm/Manifest
index c22cb1faba94..8a28a9dfaea3 100644
--- a/app-admin/diradm/Manifest
+++ b/app-admin/diradm/Manifest
@@ -1,3 +1,3 @@
DIST diradm-2.9.7.1.tar.bz2 126172 BLAKE2B 23f18a7946187caf1e12ec9d1f67a2c5c06895d837add3c79dd0b043d4745f0fd9b405e5667ebe5480946e4741c7bbff2be8c4281afcb7636353f72904f7e39b SHA512 5052f7b7072cd61eb9c70d23057f6c0d2fa68a151792d7260ca52716c9588c06234d335af84b967df23da4b4a8650502cab3b18900dc15e71f71b0888224993f
-EBUILD diradm-2.9.7.1.ebuild 2059 BLAKE2B b8c777f3131d280f344a19e5564e7c60e637949370ec59483d74b05d90c2ed0929a50f0ac148cb40f81b5b810f93416c7e305953fba9920aaf7a329e90d4795b SHA512 ba5875849b9297f0a07cae5a2511b5907763f2d6b9dc922224bfc4576d4f0dfbd151e7fc984f05460e1f36c0af91da46a27a11c4da2447620044eb448da2b287
+EBUILD diradm-2.9.7.1.ebuild 1707 BLAKE2B b006d5606650f6b1b11a165aa5f951d4593d6f2b479040b6d7955e731da352c6321c9b8bb654778742e9454df77e333a7413f3d8f1818b6bf369719bfd89ae6a SHA512 821bcdaaa0b0db69d658436e93ca400b57583b1081964ed199800c1b0ab04e9fc01052ae1ea0d038f6e0ee37f889db213b824fb5d1615e85cc770f09b190e147
MISC metadata.xml 409 BLAKE2B 9228d543861d197474a3a1e7a698b4c14fa702cc1c7454b0ceb7fcbe3b6cccc5b4d3695efb917d0d65b6907c7447a93f63412a09496048dda0a716c65160a5a6 SHA512 e9324ac84f7909c5972a7bc60d81cccddf03509f2809387b9819c67d48dfaaf080377cd6d9c624f3315bf8548a3b764d077e42636d8f51695a1837a9ebb26fb2
diff --git a/app-admin/diradm/diradm-2.9.7.1.ebuild b/app-admin/diradm/diradm-2.9.7.1.ebuild
index 40dd1892dcc6..2d6459346171 100644
--- a/app-admin/diradm/diradm-2.9.7.1.ebuild
+++ b/app-admin/diradm/diradm-2.9.7.1.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
-
-inherit eutils
+EAPI=6
DESCRIPTION="A nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP"
#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
@@ -14,13 +12,15 @@ SRC_URI="http://orbis-terrarum.net/~robbat2/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE="samba irixpasswd automount test"
+IUSE="automount irixpasswd samba test"
+REQUIRED_USE="test? ( automount irixpasswd samba )"
+
RDEPEND=">=net-nds/openldap-2.3
sys-apps/gawk
sys-apps/coreutils
sys-apps/grep
dev-lang/perl
- app-shells/bash
+ app-shells/bash:*
sys-apps/sed
virtual/perl-MIME-Base64
samba? (
@@ -36,27 +36,24 @@ DEPEND="
net-nds/openldap[-minimal]
)"
-pkg_setup() {
- use test && elog "Warning, for test usage, diradm is built with all optional features!"
+src_configure() {
+ econf \
+ $(use_enable automount) \
+ $(use_enable irixpasswd) \
+ $(use_enable samba)
}
-src_configure() {
- local myconf
- if use test; then
- myconf="--enable-samba --enable-automount --enable-irixpasswd"
- else
- myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
- fi
- econf ${myconf} || die "econf failed"
+src_test() {
+ emake -j1 check
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc CHANGES* README AUTHORS ChangeLog NEWS README.prefork \
- THANKS TODO KNOWN-BUGS || die
+ default
+ dodoc CHANGES.prefork KNOWN-BUGS
+
if use irixpasswd; then
insinto /etc/openldap/schema
- doins irixpassword.schema || die "Failed irixpassword.schema"
+ doins irixpassword.schema
fi
}
@@ -69,7 +66,3 @@ pkg_postinst() {
elog "those packages, with a further fallback to /etc/openldap/ldap.conf"
elog "for server connection settings only."
}
-
-src_test() {
- emake -j1 check
-}