summaryrefslogtreecommitdiff
path: root/app-admin/cronolog/cronolog-1.6.2-r5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cronolog/cronolog-1.6.2-r5.ebuild')
-rw-r--r--app-admin/cronolog/cronolog-1.6.2-r5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-admin/cronolog/cronolog-1.6.2-r5.ebuild b/app-admin/cronolog/cronolog-1.6.2-r5.ebuild
new file mode 100644
index 000000000000..ca4ce0c7003d
--- /dev/null
+++ b/app-admin/cronolog/cronolog-1.6.2-r5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils autotools
+
+DESCRIPTION="Log rotation software"
+HOMEPAGE="https://github.com/fordmason/cronolog"
+SRC_URI="http://cronolog.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-patches
+ # rename and move into ${PV}-patches after -r3 removal
+ "${FILESDIR}"/${P}-umask.patch
+)
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README TODO )
+
+src_prepare() {
+ default
+ mv configure.in configure.ac || die
+ eautoreconf
+}