summaryrefslogtreecommitdiff
path: root/app-admin/aws-elb-tools
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/aws-elb-tools')
-rw-r--r--app-admin/aws-elb-tools/Manifest6
-rw-r--r--app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild59
-rw-r--r--app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild60
-rw-r--r--app-admin/aws-elb-tools/metadata.xml5
4 files changed, 130 insertions, 0 deletions
diff --git a/app-admin/aws-elb-tools/Manifest b/app-admin/aws-elb-tools/Manifest
new file mode 100644
index 000000000000..dfa6ec2c8419
--- /dev/null
+++ b/app-admin/aws-elb-tools/Manifest
@@ -0,0 +1,6 @@
+DIST ElasticLoadBalancing-1.0.15.1.zip 6717939 SHA256 4b1f25de9be87ae1340426de58d966712b86baadd947ee9014d03784bcc0b5a7 SHA512 813f00d632b483a5ec98632d830be4b02fc1bc71aa7bd845faa477f7d05bda7c801e5d83992c111dfc136bf5e1204bf96b00a1c24e5b19438decb356d0841725 WHIRLPOOL b7b4d0eb103c845c887525dd33b4308ee1553b46d3d709db1231cbd972824bc99264f4f48c1229620cb27ba75ae53b8e2255fd75fc1f5c0cf8473a74b95de4a9
+EBUILD aws-elb-tools-1.0.15.1-r1.ebuild 1597 SHA256 b23f93c894dcfab4b4f883604648c8b454735d3b94f919e3304fce3020dc1fa5 SHA512 e6713f7b785b47814b20b7bb27c5c87183f30ebca7622de0de778fa9dcb716a69c5a54f177ada999b266a8df081fdf8aab1fcbfe08d8225acd111572c1c04d19 WHIRLPOOL 618ef6b0b156b77976c9373be2995c52b3c5cf97f5b75fc6dcd7c057560afe938d7a94307782c8375a293198175fb9aa208bfb00a4939d7781231ad8e077e4dc
+EBUILD aws-elb-tools-1.0.15.1.ebuild 1611 SHA256 00fe3593c434f5425a5746d6c94ea5696a706a95857df564912fc64827ace832 SHA512 5cf3b2bd5ff8c580d3adf1d144a01402cf55487ebd62ec25e9e2aaffacf32106eaa2e70b6be46a9bd6a125f8580ef2c295992651d410619f80a127f949b9ca0e WHIRLPOOL a98a4e608dd337b625892f9dc13dfe3bcdc6154bb539cb2963b970e21ba1bd1fbbad5f69b46de1ed21eb61d34cc8dc47c719729916e065add6304a6f7e22bfa5
+MISC ChangeLog 2762 SHA256 0b54e91a9e6102942bc7c7bdd9161aee755ff3642acc8b25b8e6368a41893353 SHA512 82eff7e5e02d4672adf918605f89a19d0d45e41dbf3ea3288f5a3d2b9e04d2c3858f7109c902feb3f50215f75254c8c0ac74c0adacd9ee4056b7c9658bbb4239 WHIRLPOOL 4133aff9b8c77122abdd9b2c2d395a48496ba0c39d16a2d70d1279c83f461f732bad4c932e9b6bd35d010e9b04e23d7bf2ca5e000cc5c601dfe02575b5a8fd67
+MISC ChangeLog-2015 571 SHA256 84c0ff2a410153309e037782397d838c058c09c255ef7e2478652c649cff6df8 SHA512 b34a63403d3863331c7240858f964f58aab0c790a6bba348b8babba62fc3f868b5b645c135f99d622e62fb1b1bd42c6393dd67aec7ce85f0cf3f3550f56a59cc WHIRLPOOL f13597f216feacd6d3eba67a2399fffcd0e0f08b9ba818481cf3ab60f5789a32f7966fc63140d2397b01aeb46117b936184ff0ab429898ce8f9848c12e1f2bbc
+MISC metadata.xml 166 SHA256 2caff447f5bd2701d8456ada5cc633c41ef4373fa4bfeabeb73599d40bcc941b SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84 WHIRLPOOL 1ff70497eca6531f0e0614c72a19f4b8e5ff486a58d369f4f0b36308d1d6b01168f9da887740e3b9f536236be251d3fe05f904d27a9233a7cf613416ba882968
diff --git a/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild
new file mode 100644
index 000000000000..c1738a3ffad9
--- /dev/null
+++ b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Serves as the client interface to the Elastic Load Balancing web service"
+HOMEPAGE="http://aws.amazon.com/developertools/Amazon-EC2/2536"
+SRC_URI="mirror://sabayon/${CATEGORY}/ElasticLoadBalancing-${PV}.zip"
+
+S="${WORKDIR}/ElasticLoadBalancing-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_prepare() {
+ default
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_ELB_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "THIRDPARTYLICENSE.TXT"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild
new file mode 100644
index 000000000000..23ee15e13fe6
--- /dev/null
+++ b/app-admin/aws-elb-tools/aws-elb-tools-1.0.15.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+DESCRIPTION="Serves as the client interface to the Elastic Load Balancing web service"
+HOMEPAGE="http://aws.amazon.com/developertools/Amazon-EC2/2536"
+SRC_URI="mirror://sabayon/${CATEGORY}/ElasticLoadBalancing-${PV}.zip"
+
+S="${WORKDIR}/ElasticLoadBalancing-${PV}"
+
+LICENSE="Amazon"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND="app-arch/unzip"
+RDEPEND="virtual/jre"
+RESTRICT="mirror"
+
+src_unpack() {
+ unpack ${A}
+ cd "$S"
+ find . -name '*.cmd' -delete || die
+}
+
+src_install() {
+ dodir /opt/${PN}
+ insinto /opt/${PN}/lib
+ doins -r "${S}"/lib/*
+ exeinto /opt/${PN}/bin
+ doexe "${S}"/bin/*
+
+ dodir /etc/env.d
+ cat - > "${T}"/99${PN} <<EOF
+AWS_ELB_HOME=/opt/${PN}
+PATH=/opt/${PN}/bin
+ROOTPATH=/opt/${PN}/bin
+EOF
+ doenvd "${T}"/99${PN}
+
+ dodoc "THIRDPARTYLICENSE.TXT"
+}
+
+pkg_postinst() {
+ ewarn "Remember to run: env-update && source /etc/profile if you plan"
+ ewarn "to use these tools in a shell before logging out (or restarting"
+ ewarn "your login manager)"
+ elog
+ elog "You need to put the following in your ~/.bashrc replacing the"
+ elog "values with the full path to your AWS credentials file."
+ elog
+ elog " export AWS_CREDENTIAL_FILE=/path/and_filename_of_credential_file"
+ elog
+ elog "It should contains two lines: the first line lists the AWS Account's"
+ elog "AWS Access Key ID, and the second line lists the AWS Account's"
+ elog "Secret Access Key. For example:"
+ elog
+ elog " AWSAccessKeyId=AKIAIOSFODNN7EXAMPLE"
+ elog " AWSSecretKey=wJalrXUtnFEMI/K7MDENG/bPxRfiCYzEXAMPLEKEY"
+}
diff --git a/app-admin/aws-elb-tools/metadata.xml b/app-admin/aws-elb-tools/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-admin/aws-elb-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>