summaryrefslogtreecommitdiff
path: root/app-admin/authbind/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/authbind/files')
-rw-r--r--app-admin/authbind/files/authbind-2.1.2-respect-flags.patch (renamed from app-admin/authbind/files/authbind-2.1.1-respect-flags.patch)6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch b/app-admin/authbind/files/authbind-2.1.2-respect-flags.patch
index 7e7a83e283e4..877c50bd1e9f 100644
--- a/app-admin/authbind/files/authbind-2.1.1-respect-flags.patch
+++ b/app-admin/authbind/files/authbind-2.1.2-respect-flags.patch
@@ -1,3 +1,5 @@
+diff --git a/Makefile b/Makefile
+index 37a8673..89f83f4 100644
--- a/Makefile
+++ b/Makefile
@@ -34,10 +34,9 @@ INSTALL_PROGRAM ?= install -o root -g root -m 755 -s
@@ -9,7 +11,7 @@
LIBS= -ldl -lc
-CFLAGS= -g $(OPTIMISE) \
+SHARED_LDFLAGS=
-+CFLAGS+= \
++CFLAGSS+= \
-Wall -Wwrite-strings -Wpointer-arith -Wimplicit \
-Wnested-externs -Wmissing-prototypes -Wstrict-prototypes
CPPFLAGS= -DMAJOR_VER='"$(MAJOR)"' -DMINOR_VER='"$(MINOR)"' \
@@ -17,7 +19,7 @@
helper.o authbind.o: authbind.h
$(LIBTARGET): libauthbind.o
-- ld -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
+- $(LD) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
+ $(LD) $(SHARED_LDFLAGS) -shared -soname $(LIBCANON) -o $@ $< $(LIBS)
clean distclean: