summaryrefslogtreecommitdiff
path: root/app-admin/apachetop/apachetop-0.17.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/apachetop/apachetop-0.17.4.ebuild')
-rw-r--r--app-admin/apachetop/apachetop-0.17.4.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/apachetop/apachetop-0.17.4.ebuild b/app-admin/apachetop/apachetop-0.17.4.ebuild
new file mode 100644
index 000000000000..2f5954eb82bf
--- /dev/null
+++ b/app-admin/apachetop/apachetop-0.17.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A realtime Apache log analyzer"
+HOMEPAGE="https://github.com/tessus/apachetop"
+SRC_URI="https://github.com/tessus/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="fam pcre"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ sys-libs/readline:0=
+ fam? ( virtual/fam )
+ pcre? ( dev-libs/libpcre )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-logfile="${EPREFIX}"/var/log/apache2/access_log \
+ --without-adns \
+ $(use_with fam) \
+ $(use_with pcre)
+}