summaryrefslogtreecommitdiff
path: root/app-admin/ansible-molecule
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/ansible-molecule')
-rw-r--r--app-admin/ansible-molecule/Manifest2
-rw-r--r--app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild77
2 files changed, 0 insertions, 79 deletions
diff --git a/app-admin/ansible-molecule/Manifest b/app-admin/ansible-molecule/Manifest
index fcf1e20f4a78..ed54385abd23 100644
--- a/app-admin/ansible-molecule/Manifest
+++ b/app-admin/ansible-molecule/Manifest
@@ -1,5 +1,3 @@
-DIST ansible-molecule-4.0.1.tar.gz 301517 BLAKE2B 73cf7a2257368c737b9003236bf77011de167dd6f692166702e7948c136202b33bcce1c70893b61a95af9baa90e7b5266a5fa889e3bba0e5a8c9c1e6f48fec9a SHA512 7515e07bf791d5586e1f5fb4ce0d2f731c94c8268c589155340b2bdc1528534084870e66e492b2d883f9e9764293c93799a4c75478523502a2f37ad0642a472d
DIST molecule-4.0.4.tar.gz 337260 BLAKE2B 14c493fa8aaa15466ebca19af9e5325ddb824c151d07d800136dcb714a430ea2dc42b38c9ec6e805e29ec3226376a532793d51c5d0544d6d5105510e5365ca8c SHA512 d7c1ceefbf74cbc27a397e7a40d855b23325bbde31a4cd1920961413a7db950e9fc530fec180de877eb37984bac8603033aa5a582e68e7f4c4ac2a10721c6630
-EBUILD ansible-molecule-4.0.1.ebuild 2788 BLAKE2B f8e818d42a4128e20d933ea02526e0edafa1f76c7b9c2f0ad17fd05c490fa1412f61d202f48d980442e039da45c4717d8429652bffb749e4a01eb59bccae1f32 SHA512 6117b33b0b646f3007ba0ee840f8254a5b20e8f98c70c3ad66b8d0b54cfe4aac39bb78953329ce81d0ad46ff758a8a3c47339b0d1fd6aeefee391f065b456849
EBUILD ansible-molecule-4.0.4.ebuild 2672 BLAKE2B 89d1d795f7c50189cc28c3afd6123a4b6353acec9f2f6319c7cfbf8e33b7afd70936c02f1cca85ca25f435f32b66dae14d1254412732e4f1010f500af4145171 SHA512 d79263e07cf1f6af1eb0047a1a6e12bd3ef4ed1091afaf89b7674a3fe763e349398a60bd1eac1663debe11fa42f0376d905b94d951291123e728a1cfa882138d
MISC metadata.xml 407 BLAKE2B 869b6c1d6da66568eeac2daaca56567876dbfb057f50add7bbc95fef8a3fc38b99279d359a90573f8d6af47d0e451445827f6efeefa8fb0e7954e8b624783855 SHA512 e6dbbe2c0536ea84bdfea0168a743dbe3de424b442757441bc4f978e07d41ca6022eb2d6f269c921f42b4e7d858788f967c1c35bd4241a35dbe25a161f5744de
diff --git a/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild b/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
deleted file mode 100644
index b7f03fadc438..000000000000
--- a/app-admin/ansible-molecule/ansible-molecule-4.0.1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_10 )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1 optfeature
-
-MY_PN="${PN#ansible-}"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A toolkit designed to aid in the development and testing of Ansible roles"
-HOMEPAGE="https://pypi.org/project/molecule/ https://github.com/ansible-community/molecule/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv"
-IUSE="selinux"
-
-RDEPEND="$(python_gen_cond_dep '
- >=dev-python/ansible-compat-2.2.0[${PYTHON_USEDEP}]
- dev-python/cerberus[${PYTHON_USEDEP}]
- >=dev-python/click-8.0[${PYTHON_USEDEP}]
- >=dev-python/click-help-colors-0.9[${PYTHON_USEDEP}]
- >=dev-python/enrich-1.2.7[${PYTHON_USEDEP}]
- >=dev-python/jinja-2.11.3[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-4.9.1[${PYTHON_USEDEP}]
- dev-python/packaging[${PYTHON_USEDEP}]
- <dev-python/pluggy-2.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/rich-9.5.1[${PYTHON_USEDEP}]
- >=dev-util/cookiecutter-1.7.3[${PYTHON_USEDEP}]
- selinux? ( sys-libs/libselinux[python,${PYTHON_USEDEP}] )
-')"
-BDEPEND="$(python_gen_cond_dep '
- >=dev-python/setuptools-scm-3.5.0[${PYTHON_USEDEP}]
- >=dev-python/setuptools_scm_git_archive-1.1[${PYTHON_USEDEP}]
- doc? (
- app-admin/ansible-core[${PYTHON_USEDEP}]
- dev-python/ansible-pygments[${PYTHON_USEDEP}]
- >=dev-python/simplejson-3.17.2[${PYTHON_USEDEP}]
- )
- test? (
- >=dev-python/ansi2html-1.6.0[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- <dev-python/pexpect-5[${PYTHON_USEDEP}]
- >=dev-python/pytest-mock-3.3.1[${PYTHON_USEDEP}]
- >=dev-python/pytest-plus-0.2[${PYTHON_USEDEP}]
- >=dev-python/pytest-testinfra-6.1.0[${PYTHON_USEDEP}]
- >=dev-python/pytest-xdist-2.1.0[${PYTHON_USEDEP}]
- dev-util/yamllint
- )
-')"
-
-S="${WORKDIR}"/${MY_P}
-
-# test_role.py doesn't play nicely with FEATURES=usersandbox. As for test_command.py:
-# - quite a few of these tests use the network;
-# - test_command_dependency[shell] only works if Molecule has previously been installed;
-# - tests involving creation of a new scenario fail on ansible-lint errors, even though
-# a config file is deployed which should skip expected issues.
-EPYTEST_DESELECT=(
- src/molecule/test/functional/test_command.py
- src/molecule/test/unit/command/init/test_role.py
-)
-
-distutils_enable_sphinx docs '>=dev-python/sphinx-notfound-page-0.7.1' '<dev-python/sphinx_ansible_theme-0.10.0'
-distutils_enable_tests pytest
-
-pkg_postinst() {
- optfeature_header "Some optional packages commonly used in Molecule scenarios:"
- optfeature "checking playbooks for practices and behaviour that can be improved" app-admin/ansible-lint
-}