summaryrefslogtreecommitdiff
path: root/app-admin/abrt
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/abrt')
-rw-r--r--app-admin/abrt/Manifest2
-rw-r--r--app-admin/abrt/abrt-2.14.5.ebuild129
2 files changed, 131 insertions, 0 deletions
diff --git a/app-admin/abrt/Manifest b/app-admin/abrt/Manifest
index 68357ed72493..05db82fbd9c6 100644
--- a/app-admin/abrt/Manifest
+++ b/app-admin/abrt/Manifest
@@ -1,5 +1,7 @@
AUX abrt-2.0.12-r1-conf 687 BLAKE2B 771c5370e3f7f181c22f8a56d8a13a02759aed2fdd5f7182d4bf9e7bebf1f80f6178acbce4ffddff7ab292c773685148621d53528b96c3099d96dcd0f26b1280 SHA512 8dc19a07ca57a7a95184366e747f20e36b97eea6423aafb88390f9754f90bfa76b6d0c33806c714fcadfebeebda05e989b282bf07cd0ce50cf01efa8721357f2
AUX abrt-2.0.12-r1-init 1921 BLAKE2B dc8bbe3d4902ac65165f1e71eb6400810980f6b90014619aa87614f0a8e1c6e9bb79afa964e5c0324ca090fefa9b90f2705c7388b488709f31619d824850e3e8 SHA512 a6f7c4029f974af083f33020756bc0eaa877c23f658d6b92388627e3a923aae499dd44e1b0e22af792a6c431a683ebe4604d6dec62bf09f70a2a5209cd45be81
DIST abrt-2.14.2.tar.gz 6113632 BLAKE2B 904ec2ca4c3aa70b62573ca2730742689f4446c1e5f04bfb6dc4267a4a9a6d44ef8c2b6e82c1e0aba04876b400c3a965a879da65bbff7ec729846f1b5c28cdf9 SHA512 82ba10cb151b4585024e3dfc626f46a7d967797e0375158cd76355c4f6a66c59578cc7b41bc5d5aaa3e694b3653b8658650df458676225660cfe95ec318c6886
+DIST abrt-2.14.5.tar.gz 6056105 BLAKE2B 22e797a431237bd3d4ef6f2467842c5f08e2ef3ca51e7857e3c55e45ed93a9499843fe40b081c70affb5def8f2cfe78d61e865c51c969fb2c9936225bdfe4996 SHA512 a8672735c6d3263ddff006e6e186d9b71e6d9375a8c909c2a85bbbf736a6687b6fe4aa74640a07664f14fd886895a86babf41218a8c2365d6fccd347630ccc9e
EBUILD abrt-2.14.2.ebuild 3153 BLAKE2B 90814321779be2e6e624d3eaac8e0a910e11e8379c04c0d408a70b5561c4f2ce560b126887e24d72884eb9553f0c8ba00c860b775286ae5279853770cf9e6d53 SHA512 0fe5f288ebc6a9937f9cbc9634801b4c92d0e84fb3bd4b679974f8f0759d2d2bb9710bdc70462dbaf73904d9f57c332746fe93fb7dfba5ed3a9863ecbd9e8d32
+EBUILD abrt-2.14.5.ebuild 3153 BLAKE2B 90814321779be2e6e624d3eaac8e0a910e11e8379c04c0d408a70b5561c4f2ce560b126887e24d72884eb9553f0c8ba00c860b775286ae5279853770cf9e6d53 SHA512 0fe5f288ebc6a9937f9cbc9634801b4c92d0e84fb3bd4b679974f8f0759d2d2bb9710bdc70462dbaf73904d9f57c332746fe93fb7dfba5ed3a9863ecbd9e8d32
MISC metadata.xml 327 BLAKE2B 856e3ab03170c985b08a7c11282af63794b0447b04d221803badcb19a9145adaa91d7637a6fe864618c469d2dfa7796bb39a3ef5ab2116eb7861f2793961dd0b SHA512 4ab7758c443c8c34f579d9b89e9b2c8aeeaf2b83f8bef397d1d56e24779708e761324eea26c0ef69283c9a018b7e7f82492a534683509040facefa382d9a3acb
diff --git a/app-admin/abrt/abrt-2.14.5.ebuild b/app-admin/abrt/abrt-2.14.5.ebuild
new file mode 100644
index 000000000000..16a5250da01e
--- /dev/null
+++ b/app-admin/abrt/abrt-2.14.5.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools python-single-r1 xdg-utils
+
+DESCRIPTION="Automatic bug detection and reporting tool"
+HOMEPAGE="https://github.com/abrt/abrt/wiki/ABRT-Project"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=dev-libs/glib-2.56:2
+ >=dev-libs/libreport-2.13.0[gtk,python]
+ dev-libs/libxml2:2
+ >=gnome-base/gsettings-desktop-schemas-3.15.1
+ net-libs/libsoup:2.4
+ sys-apps/dbus
+ sys-apps/systemd:0=
+ sys-auth/polkit
+ sys-libs/libcap
+ sys-fs/inotify-tools
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}
+ acct-user/abrt
+ acct-group/abrt
+ app-arch/cpio
+ app-arch/rpm[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/elfutils
+ dev-libs/json-c:0=
+ sys-apps/util-linux
+ >=sys-devel/gdb-7
+ $(python_gen_cond_dep '
+ dev-libs/satyr[${PYTHON_MULTI_USEDEP}]
+ dev-python/argcomplete[${PYTHON_MULTI_USEDEP}]
+ dev-python/argh[${PYTHON_MULTI_USEDEP}]
+ dev-python/humanize[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep 'dev-python/pytest[${PYTHON_MULTI_USEDEP}]')
+ )
+ app-text/asciidoc
+ app-text/xmlto
+ >=dev-util/intltool-0.35.0
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17
+"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ python_fix_shebang .
+ default
+
+ # Install under proper directory
+ sed -i -e 's:dbusabrtdocdir = ${datadir}/doc/abrt-dbus-${VERSION}/html:dbusabrtdocdir = ${datadir}/doc/${PF}/html:' doc/problems-service/Makefile.am || die
+
+ # Ensure this works for systems with and without /usr merge
+ sed -i -e "s:/usr/bin/bash:$(which bash):" init-scripts/abrtd.service || die
+
+ # Fix hardcoded "pytest-3"
+ sed -i -e "s:pytest-3:pytest:" \
+ configure.ac src/python-problem/tests/Makefile.am src/cli/test || die
+
+ # pyhook test is sensitive to the format of python's error messages, and
+ # fails with certain python versions
+ sed -e '/pyhook.at/ d' \
+ -i tests/Makefile.* tests/testsuite.at || die "sed remove pyhook tests failed"
+ ./gen-version || die # Needed to be run before autoreconf
+ eautoreconf
+}
+
+src_configure() {
+ myeconfargs=(
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --localstatedir="${EPREFIX}/var"
+ --without-bodhi
+ # package breaks due to not finding libreport-web with bodhi plugin enabled
+ --without-rpm
+ $(usex selinux "" "--without-selinux")
+ --with-python3
+ --without-pythondoc
+ # package breaks due to no sphinx-build-3
+ $(use_with test pythontests)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ keepdir /var/run/abrt
+ # /var/spool/abrt is created by dev-libs/libreport
+
+ diropts -m 700 -o abrt -g abrt
+ keepdir /var/spool/abrt-upload
+
+ diropts -m 775 -o abrt -g abrt
+ keepdir /var/cache/abrt-di
+
+ find "${D}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}/${PN}-2.0.12-r1-init" abrt
+ newconfd "${FILESDIR}/${PN}-2.0.12-r1-conf" abrt
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}