summaryrefslogtreecommitdiff
path: root/app-accessibility/speech-dispatcher
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/speech-dispatcher')
-rw-r--r--app-accessibility/speech-dispatcher/Manifest2
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r3.ebuild112
2 files changed, 0 insertions, 114 deletions
diff --git a/app-accessibility/speech-dispatcher/Manifest b/app-accessibility/speech-dispatcher/Manifest
index ed95024c3914..0a1f5ac67ef3 100644
--- a/app-accessibility/speech-dispatcher/Manifest
+++ b/app-accessibility/speech-dispatcher/Manifest
@@ -1,6 +1,4 @@
AUX speech-dispatcher-0.9.1-fno-common.patch 13112 BLAKE2B 6a4125117852cfe250bed1a9936af67a2a83303ecced615febd89b9b14918dda94a78862cdcceb95fcea3ea7ed30a12d799afbc21264ff386c94f9f867eb8136 SHA512 b957ebbfd8a6a9cfe2b85cba85b77dc813e76212721d63d42b3881ed17993d7b4a8c720d4c431c8e2eb3ea60996e411402732c735948f37fa84a9fdcfa2683fc
-DIST speech-dispatcher-0.8.7.tar.gz 1333677 BLAKE2B 0b08f1a1228fe1240e14b3d52913f8fa64a1f2ee9b563294b49ea8d3e5cfd3041aa5572ec72354b360dabd2d263deb79e418b95b6174a5b89ee541e9fd23c7e2 SHA512 0e7af02e8521aa8d397ea4d0329f9a8d56970beed645456dfedc738ececd2ccd8ecfdf66e92ae852878a473ba991175e1d4dc2b8b0148c958163682b49678375
DIST speech-dispatcher-0.9.1.tar.gz 1662222 BLAKE2B 03c3d79a9cbbe7e549f638992fb276ab2270a45a057708721666257699479b3feb81daddf26d8032ba3f7b9ab6b836c7f582ee22a532ff018c99820af3864d87 SHA512 35adb353d22b8dff8884cb20f3836f96f4f74b272bbd442d522a10a3d3b91a0da6705e6c216764f295208b5446c2077da620de2a81cafe5a0c4dd826e33753c2
-EBUILD speech-dispatcher-0.8.7-r3.ebuild 2667 BLAKE2B f060b83425cdcade72424fd4ba45cb7f853bdd98585bdd11836ea9d273c725867798abc6fc7772054ba62926544e6bd8a43598651f937c0592b14193e8c671ae SHA512 a9a2a4974d51741ae01217e413af49b01ddf388eafea99668e8f43111275cceeaf8860c1a7d0abe7ad0baf1fdb91326e426734985652d47f66895d72bd5ed274
EBUILD speech-dispatcher-0.9.1.ebuild 2791 BLAKE2B 9dd04093e1d78b4afd0867c047d76bcb138eacc61d9ce18bac4d7cd434634ae04d93c0142aef18aca3158bea10b091937c207a5ca99ce55f6a40cc9b5c91101f SHA512 6f59003c51703b0ba3ee809abfc1ecd94daf388cbc224cdf3cc13900d4634c156f532b2bb095ebac004c67af0c16b3680c33cead6c8384c71109cfa7c120a9ec
MISC metadata.xml 632 BLAKE2B 2a60d2e822db36bf3f0547d97ccaad05d6bcce11afa71534b108358f1d71f857f200907f01c31c3083a5196e43eb681c06e2991a086c91731daced3f56282c2d SHA512 db94cba99bd2c9bbfe98b1647ac53a3861cbd697df791bea025e2a713a5991ca6929f2bc82a985ba38eef4a2571515d96aac6558fe143b68e24713490c12dd0a
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r3.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r3.ebuild
deleted file mode 100644
index 3cdd6a3eb2a7..000000000000
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.8.7-r3.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit eutils python-r1
-
-DESCRIPTION="Speech synthesis interface"
-HOMEPAGE="http://www.freebsoft.org/speechd"
-SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="alsa ao +espeak flite nas pulseaudio python"
-
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
-DEPEND="python? ( ${PYTHON_DEPS} )
- >=dev-libs/dotconf-1.3
- >=dev-libs/glib-2.28:2
- dev-libs/libltdl:0
- >=media-libs/libsndfile-1.0.2
- alsa? ( media-libs/alsa-lib )
- ao? ( media-libs/libao )
- espeak? ( app-accessibility/espeak )
- flite? ( app-accessibility/flite )
- nas? ( media-libs/nas )
- pulseaudio? ( media-sound/pulseaudio )"
-RDEPEND="${DEPEND}
- python? ( dev-python/pyxdg[${PYTHON_USEDEP}] )"
-BDEPEND="
- >=dev-util/intltool-0.40.0
- virtual/pkgconfig"
-
-src_configure() {
- # bug 573732
- export GIT_CEILING_DIRECTORIES="${WORKDIR}"
-
- local myeconfargs=(
- --disable-python
- --disable-static
- $(use_with alsa)
- $(use_with ao libao)
- $(use_with espeak)
- $(use_with flite)
- $(use_with pulseaudio pulse)
- $(use_with nas)
- )
- econf ${myeconfargs[@]}
-}
-
-src_compile() {
- use python && python_copy_sources
-
- emake
-
- if use python; then
- building() {
- cd src/api/python || die
- emake \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
- }
- python_foreach_impl run_in_build_dir building
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc ANNOUNCE AUTHORS BUGS FAQ NEWS README*
-
- if use python; then
- installation() {
- cd src/api/python || die
- emake \
- DESTDIR="${D}" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)" \
- install
- }
- python_foreach_impl run_in_build_dir installation
- python_replicate_script "${ED}"/usr/bin/spd-conf
- fi
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- local editconfig="n"
- if ! use espeak; then
- ewarn "You have disabled espeak, which is speech-dispatcher's"
- ewarn "default speech synthesizer."
- ewarn
- editconfig="y"
- fi
- if ! use pulseaudio; then
- ewarn "You have disabled pulseaudio support."
- ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
- ewarn
- editconfig="y"
- fi
- if [[ "${editconfig}" == "y" ]]; then
- ewarn "You must edit ${EROOT}/etc/speech-dispatcher/speechd.conf"
- ewarn "and make sure the settings there match your system."
- ewarn
- fi
- elog "For festival support, you need to"
- elog "install app-accessibility/festival-freebsoft-utils."
-}