summaryrefslogtreecommitdiff
path: root/app-accessibility/sound-icons
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/sound-icons')
-rw-r--r--app-accessibility/sound-icons/Manifest5
-rw-r--r--app-accessibility/sound-icons/metadata.xml14
-rw-r--r--app-accessibility/sound-icons/sound-icons-0.1.ebuild28
3 files changed, 47 insertions, 0 deletions
diff --git a/app-accessibility/sound-icons/Manifest b/app-accessibility/sound-icons/Manifest
new file mode 100644
index 000000000000..c89c2d3e1ff2
--- /dev/null
+++ b/app-accessibility/sound-icons/Manifest
@@ -0,0 +1,5 @@
+DIST sound-icons-0.1.tar.gz 591196 SHA256 382dda1d14a07b3125a8b5084695aa9ba5cb0fff02e5aab69fd6c7e23cbcf4d7 SHA512 f0ba9e1e84ace325671c7f323f01d647aa0e1a318e9adc2a6d8af4e0d795e478b2ea66007670f9c7ced9ef7310fdbccb5168b0f404579f5dff8712fe12ad93a0 WHIRLPOOL cacf8afc80819d99fed82a91ec2e82bee9f096483b7334364294bbd5c016e80f9f1fa200416f86c9dc54a8799824eaee7db1eec3c8ca0c506b7a784e2761a70e
+EBUILD sound-icons-0.1.ebuild 674 SHA256 4c737bfebcbe3a8da9b5f118fa3658ec7101be3023a864818efd0708ae37c581 SHA512 81f169584a6256f31b3f3f847ae0ab3613123063d1f8bae973586ded0a8e32116b109a88d7a0117a524dd94a6acd35449287dde90ea6b9a3c1949131b2014cce WHIRLPOOL 081cf8940707d81928a2078199cf1e8f520421813a7de7a82fd757530e54fcc803a9d2597967c591e65cb3c4c8fdf883096666c34626e6eac7c835d2d1f79154
+MISC ChangeLog 2444 SHA256 165e84d195694f708cf70d9f3cd7770de2c2205a82e5bcf77dbef607687ed3cd SHA512 99eff23287605a7b45937c7459b95468995dc1598123142a77228594eb04d82c9621d85ebe0563f009b4667121bc2a3e79b8f3b4939ffe163316d61b02ca1b79 WHIRLPOOL 30bd19a9af9830c369ffbf6500373c69023062143e44036f761922bbe2af8ddd6ad714e01df0b8efca13d685b19b910aeac90ca2509c2ff30f42138e4ee6af88
+MISC ChangeLog-2015 661 SHA256 9b1cd7d560060707c91e06cb95c436e689c8ad541cbc4d4f0cb54ec5a0823c2d SHA512 4c416d4bcf1516d1c74be7b760e38094b755ce66936cf746dd159794e71fba77ef92bc9d0afa28b5d06fcacd5a655fb275bcdc9771df587e59ad7fed4553e1e8 WHIRLPOOL e805012cd82210e6634b6f0eeb5bdd425f99c6c6a27c2e18cf8c95bc9ae862e1e777494881a4b2fa8883e74a5d8ebf30793b15f0c644107483a383d795769387
+MISC metadata.xml 468 SHA256 f98f223c8b5b6c23e9ec8d3ad4585e63f4cab2251786b27032ed07013f2aa96a SHA512 9ab288130466bb7e5574fb54cf239a7ff0b5415e24b02f022df013fd3eb1ef8f733b7e1e310a2305f816de797ab592db7a3c7e33af46fea05e39139536b0f611 WHIRLPOOL a57c2a4007b8cb9d9d33abcd540bbd158a49dc4d237170f6f51b20247a43f0bd53dd1efa51c3748d02dcd9a4557223f92a146b314ef28bc6a7a6e050d1e914b7
diff --git a/app-accessibility/sound-icons/metadata.xml b/app-accessibility/sound-icons/metadata.xml
new file mode 100644
index 000000000000..4e89c04468b7
--- /dev/null
+++ b/app-accessibility/sound-icons/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>williamh@gentoo.org</email>
+</maintainer>
+<maintainer type="project">
+ <email>accessibility@gentoo.org</email>
+ <name>Gentoo Accessibility Project</name>
+</maintainer>
+<longdescription lang="en">
+This is a collection of sound icons which can be used by speech dispatcher.
+</longdescription>
+</pkgmetadata>
diff --git a/app-accessibility/sound-icons/sound-icons-0.1.ebuild b/app-accessibility/sound-icons/sound-icons-0.1.ebuild
new file mode 100644
index 000000000000..1fe8a80f3b2e
--- /dev/null
+++ b/app-accessibility/sound-icons/sound-icons-0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DESCRIPTION="a collection of Sound Icons for speech-dispatcher"
+HOMEPAGE="http://www.freebsoft.org"
+SRC_URI="http://www.freebsoft.org/pub/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+RDEPEND="app-accessibility/speech-dispatcher"
+
+src_compile(){
+ einfo "Nothing to compile."
+}
+
+src_install() {
+ dodoc README
+ insinto /usr/share/sounds/sound-icons
+ doins "${S}"/*.wav
+ links="`find ${S} -type l -print`"
+ for link in $links; do
+ target=`readlink -n $link`
+ dosym $target /usr/share/sounds/sound-icons/`basename $link`
+ done
+}