summaryrefslogtreecommitdiff
path: root/app-accessibility/simon
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/simon')
-rw-r--r--app-accessibility/simon/Manifest2
-rw-r--r--app-accessibility/simon/metadata.xml13
-rw-r--r--app-accessibility/simon/simon-9999.ebuild76
3 files changed, 0 insertions, 91 deletions
diff --git a/app-accessibility/simon/Manifest b/app-accessibility/simon/Manifest
deleted file mode 100644
index f06657f665c6..000000000000
--- a/app-accessibility/simon/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-EBUILD simon-9999.ebuild 2058 BLAKE2B 5cdd32e8b39ce6b43ace50f615160bfce2e60ddc9534845771d5696de494c1d4822fe7b4a47dce519b42a61206b0166214feb1c7b040cc4ab52d07de3d133511 SHA512 630dda06440102440ee0f833aeab94140dc65b6ee00df95442bca853993d49a3f1ec50cc090dea339ddb3fded4a0f3ffa3e4cb9bcd4eb0b84e95851fe3ddac52
-MISC metadata.xml 526 BLAKE2B 90a5578ad2dd40b107c0a810ac487cf2c952f056bc8c6bb109cfceda2b66cdfc2ccc027e741d2eb0a4ee77e9ac349f43f7724b126d077c988ba4dd3c0c940375 SHA512 ab2dbc917334c5877b7654179b0f28e7d2824d98ba68c62e13ab912f5c1010198b8891ea5764c9e304727ac18be28b758f23f414e145047f99caef335006659d
diff --git a/app-accessibility/simon/metadata.xml b/app-accessibility/simon/metadata.xml
deleted file mode 100644
index 923816d1f30f..000000000000
--- a/app-accessibility/simon/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>accessibility@gentoo.org</email>
- <name>Gentoo Accessibility Project</name>
- </maintainer>
- <use>
- <flag name="opencv">Use <pkg>media-libs/opencv</pkg></flag>
- <flag name="pim">Enable support for KDE PIM resources integration</flag>
- <flag name="sphinx">Build sphinx backend (pulls <pkg>app-accessibility/julius</pkg> if disabled</flag>
- </use>
-</pkgmetadata>
diff --git a/app-accessibility/simon/simon-9999.ebuild b/app-accessibility/simon/simon-9999.ebuild
deleted file mode 100644
index f5fc867b2122..000000000000
--- a/app-accessibility/simon/simon-9999.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_BRANCH="kf5"
-KDE_HANDBOOK="forceoptional"
-KDE_TEST="forceoptional"
-inherit kde5
-
-DESCRIPTION="Open-source speech recognition program for replacing mouse and keyboard"
-HOMEPAGE="http://simon-listens.org/"
-[[ ${PV} != *9999* ]] && SRC_URI="mirror://kde/unstable/simon/${PV}/${P}.tar.xz"
-
-LICENSE="GPL-2"
-KEYWORDS=""
-IUSE="libsamplerate opencv pim sphinx"
-
-DEPEND="
- $(add_frameworks_dep karchive)
- $(add_frameworks_dep kcmutils)
- $(add_frameworks_dep kcompletion)
- $(add_frameworks_dep kconfig)
- $(add_frameworks_dep kconfigwidgets)
- $(add_frameworks_dep kcoreaddons)
- $(add_frameworks_dep kcrash)
- $(add_frameworks_dep kdbusaddons)
- $(add_frameworks_dep kdelibs4support)
- $(add_frameworks_dep kguiaddons)
- $(add_frameworks_dep khtml)
- $(add_frameworks_dep ki18n)
- $(add_frameworks_dep kiconthemes)
- $(add_frameworks_dep kio)
- $(add_frameworks_dep kparts)
- $(add_frameworks_dep ktexteditor)
- $(add_frameworks_dep kwidgetsaddons)
- $(add_frameworks_dep kxmlgui)
- $(add_kdeapps_dep okular)
- $(add_qt_dep qtconcurrent)
- $(add_qt_dep qtdbus)
- $(add_qt_dep qtgui)
- $(add_qt_dep qtnetwork)
- $(add_qt_dep qtsql)
- $(add_qt_dep qtwidgets)
- $(add_qt_dep qtxml)
- $(add_qt_dep qtx11extras)
- media-libs/alsa-lib
- media-libs/libqaccessibilityclient:5
- x11-libs/libX11
- x11-libs/libXtst
- x11-libs/qwt:6=[qt5]
-"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_find_package pim KF5CalendarCore)
- $(cmake-utils_use_find_package pim KF5Akonadi)
- -DWITH_LibSampleRate=$(usex libsamplerate)
- -DWITH_OpenCV=$(usex opencv)
- -DBackendType=$(usex sphinx "both" "jhtk")
- $(cmake-utils_use_find_package sphinx Sphinxbase)
- $(cmake-utils_use_find_package sphinx Pocketsphinx)
- -DQWT_INCLUDE_DIR=/usr/include/qwt6
- -DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt5.so
- )
-
- kde5_src_configure
-}
-
-pkg_postinst() {
- kde5_pkg_postinst
-
- elog "Optional dependency:"
- use sphinx && elog " app-accessibility/julius (alternative backend)"
-}