summaryrefslogtreecommitdiff
path: root/app-accessibility/espeak-ng
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/espeak-ng')
-rw-r--r--app-accessibility/espeak-ng/Manifest5
-rw-r--r--app-accessibility/espeak-ng/espeak-ng-1.50-r1.ebuild82
-rw-r--r--app-accessibility/espeak-ng/espeak-ng-1.50.ebuild8
-rw-r--r--app-accessibility/espeak-ng/espeak-ng-9999.ebuild11
4 files changed, 93 insertions, 13 deletions
diff --git a/app-accessibility/espeak-ng/Manifest b/app-accessibility/espeak-ng/Manifest
index a29f7d94178a..609b35403f3e 100644
--- a/app-accessibility/espeak-ng/Manifest
+++ b/app-accessibility/espeak-ng/Manifest
@@ -1,4 +1,5 @@
DIST espeak-ng-1.50.tar.gz 13665536 BLAKE2B c64c2a474374d4b6fe13bf3a99f5dfb661923c13ebd6c0bc323e7f26d9d90945c7075cc5c8f4b51e5db3303632c8c9daca7a65a1883e09d7c3faf63dd725ea3f SHA512 297dd80a6cdae3e2b8acf6823475220ce89d6a5fb68ea303156ad52cb3e7388049b6921759d4ed4e3d2e2ebd19bf931259e454f74a2ac0b7ecf4ce56c1d60c0c
-EBUILD espeak-ng-1.50.ebuild 1706 BLAKE2B bafd021df493c51764ec7341c191e6f12e907886deb3deebca7a7b44e791c9bbe7bb29b50e2e259948dde0970b9fb541469601f8529132f8a1d9c8b49d3ea108 SHA512 5b98b7e7d4fc8e9bbdda58579920aca7a2352f8f88a49861790b743c767d15efbd61f196263839d3fe88549ba2668c4d083148ae456dc2b15bb68e52622be99c
-EBUILD espeak-ng-9999.ebuild 1643 BLAKE2B c37bf379661ac3fdaf2bc6078868de82d57620dcbb0ce101065f28e275c985dbf034481bb7544dbf6858e1bd283f077f4f6eac01a2dc97b3333a2ea78e315c21 SHA512 1dc4ec1cfb1b317cfe645ba7f30a09689d00bad68f367d74e4564626535f564493f890cf26efc1738b8df084fc68b94a3a31407ff3eade05c1f189fc836105c4
+EBUILD espeak-ng-1.50-r1.ebuild 1898 BLAKE2B a384af7522e1d9d48d91544986bb93f90bdafb63982ae6d10de94aa45891e921ad61d51f75397d9b31e475b180d1cc4353cd312e5495f95a3aedb9a7031ab20d SHA512 bec76f91cb05ac7395b8af13c26dbc3eae16146488e74c0191bc0b664666a67f25a89cf467f5f188d4718e057e53f10ec791be97e7628530db9d62cfde097327
+EBUILD espeak-ng-1.50.ebuild 1848 BLAKE2B c853ba207b5e6e119dd070486482eb136989866eae777ffe404f3780ea6c5484bdf6b16e763fba52602389f61620010d55b93be3ef4d2aad47071aa449268feb SHA512 3c4dbf0255ad975c69e373e20497b3eeaa9946931ab92f97b0b455a76a0d9a57c75717b109902b07471ee9cf342758a30d4556c5ea4087196831a991d1dfd3b8
+EBUILD espeak-ng-9999.ebuild 1620 BLAKE2B 5b102df468174042f218e2c5ea93bf4997f67ba5c8a0a20b70836aa5ad3b3896a21d73a11795eec07c367c76207a837308388895486f8a3faa836b4d857aec7a SHA512 f62c64049b7908c8f2282f029f89aa5762b8f03ca6b76de84e01da8d125a9388c6b35ed25f2ab3a9b2691f2de376a54f61cc1c0e57043424df52ed9999dcdefb
MISC metadata.xml 959 BLAKE2B cf593df0a2ac774e7ba15f77fc8b9cda2907d9d721c61fa602df8653f4019ed46fdadc39353c7ca4f1dbc46245ff28c922fe2844d49c5346a1b7fa7f02005c3b SHA512 4dce4bcbaf2dbd3bbfd0f6503884dc47690d648ce04c489688818aaef15e555fb76e33a49a484e8197631b2885297541f4ef80d0074d44d3f44aeb923a3ea698
diff --git a/app-accessibility/espeak-ng/espeak-ng-1.50-r1.ebuild b/app-accessibility/espeak-ng/espeak-ng-1.50-r1.ebuild
new file mode 100644
index 000000000000..9b3280273ec1
--- /dev/null
+++ b/app-accessibility/espeak-ng/espeak-ng-1.50-r1.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Software speech synthesizer for English, and some other languages"
+HOMEPAGE="https://github.com/espeak-ng/espeak-ng"
+SRC_URI="https://github.com/espeak-ng/espeak-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+ Turkowski unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="+async +klatt l10n_ru l10n_zh man mbrola +sound"
+
+COMMON_DEPEND="
+ !app-accessibility/espeak
+ mbrola? ( app-accessibility/mbrola )
+ sound? ( media-libs/pcaudiolib )
+"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ sound? ( media-sound/sox )
+"
+BDEPEND="
+ virtual/pkgconfig
+ man? ( || ( app-text/ronn-ng app-text/ronn ) )
+"
+
+DOCS=( CHANGELOG.md README.md docs )
+
+src_prepare() {
+ default
+
+ # disable failing tests
+ rm tests/{language-pronunciation,translate}.test || die
+ sed -i \
+ -e "/language-pronunciation.check/d" \
+ -e "/translate.check/d" \
+ Makefile.am || die
+
+ # https://github.com/espeak-ng/espeak-ng/issues/699
+ # fixed in master
+ sed -i -e "s/int samplerate;/static int samplerate;/" src/espeak-ng.c || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local econf_args
+ econf_args=(
+ $(use_with async)
+ $(use_with klatt)
+ $(use_with l10n_ru extdict-ru)
+ $(use_with l10n_zh extdict-zh)
+ $(use_with l10n_zh extdict-zhy)
+ $(use_with mbrola)
+ $(use_with sound pcaudiolib)
+ --without-libfuzzer
+ --without-sonic
+ --disable-rpath
+ --disable-static
+ )
+ econf "${econf_args[@]}"
+}
+
+src_compile() {
+ # see docs/building.md
+ # The -j1s from compile/test/install may be droppable in next release
+ # (after 1.50). Several bugs have been fixed upstream in git.
+ emake -j1
+}
+
+src_test() {
+ emake check -j1
+}
+
+src_install() {
+ emake DESTDIR="${D}" VIMDIR=/usr/share/vimfiles install -j1
+ rm "${ED}"/usr/lib*/*.la || die
+}
diff --git a/app-accessibility/espeak-ng/espeak-ng-1.50.ebuild b/app-accessibility/espeak-ng/espeak-ng-1.50.ebuild
index de70028fc38a..c9289793f7fa 100644
--- a/app-accessibility/espeak-ng/espeak-ng-1.50.ebuild
+++ b/app-accessibility/espeak-ng/espeak-ng-1.50.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -67,14 +67,16 @@ src_configure() {
src_compile() {
# see docs/building.md
+ # The -j1s from compile/test/install may be droppable in next release
+ # (after 1.50). Several bugs have been fixed upstream in git.
emake -j1
}
src_test() {
- emake check
+ emake check -j1
}
src_install() {
- emake DESTDIR="${D}" VIMDIR=/usr/share/vimfiles install
+ emake DESTDIR="${D}" VIMDIR=/usr/share/vimfiles install -j1
rm "${ED}"/usr/lib*/*.la || die
}
diff --git a/app-accessibility/espeak-ng/espeak-ng-9999.ebuild b/app-accessibility/espeak-ng/espeak-ng-9999.ebuild
index 941edd1d327b..9012010b2cae 100644
--- a/app-accessibility/espeak-ng/espeak-ng-9999.ebuild
+++ b/app-accessibility/espeak-ng/espeak-ng-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -13,7 +13,7 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
else
SRC_URI="https://github.com/espeak-ng/espeak-ng/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
+ KEYWORDS="~amd64 ~riscv"
fi
LICENSE="GPL-3+ Turkowski unicode"
@@ -31,7 +31,7 @@ RDEPEND="${COMMON_DEPEND}
"
BDEPEND="
virtual/pkgconfig
- man? ( app-text/ronn )
+ man? ( || ( app-text/ronn-ng app-text/ronn ) )
"
DOCS=( CHANGELOG.md README.md docs )
@@ -67,11 +67,6 @@ src_configure() {
econf "${econf_args[@]}"
}
-src_compile() {
- # see docs/building.md
- emake -j1
-}
-
src_test() {
emake check
}