summaryrefslogtreecommitdiff
path: root/app-accessibility/brltty/files
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/brltty/files')
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch56
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-major.patch59
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-respect-AR.patch12
-rw-r--r--app-accessibility/brltty/files/brltty-5.2-udev.patch28
-rw-r--r--app-accessibility/brltty/files/brltty.rc12
-rw-r--r--app-accessibility/brltty/files/brltty.tmpfiles.conf1
6 files changed, 168 insertions, 0 deletions
diff --git a/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
new file mode 100644
index 000000000000..e60ea9a4e509
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-fix-ldflags.patch
@@ -0,0 +1,56 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -377,7 +377,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|cygwin*|mingw*|elf*)
+- brltty_mkmod_ld_make="-shared"
++ brltty_mkmod_ld_make="-shared ${LDFLAGS}"
+ ;;
+ solaris*)
+ brltty_mkmod_ld_make="-G"
+@@ -404,7 +404,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
++ brltty_cv_prog_mkmod="\$(CC) ${brltty_mkmod_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mkmod_ld_options}]) -o"
+ else
+ brltty_cv_prog_mkmod="\$(LD) ${brltty_mkmod_ld_make} ${brltty_mkmod_ld_options} -o"
+ fi])
+@@ -414,7 +414,7 @@
+ case "${host_os}"
+ in
+ linux*|gnu*|openbsd*|freebsd*|kfreebsd*|netbsd*|*qnx*|elf*)
+- brltty_mklib_ld_make="-shared"
++ brltty_mklib_ld_make="-shared ${LDFLAGS}"
+ brltty_mklib_ld_options="-soname"
+ ;;
+ solaris*)
+@@ -449,7 +449,7 @@
+ esac
+ if test "${GCC}" = "yes"
+ then
+- brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
++ brltty_cv_prog_mklib="\$(CC) ${brltty_mklib_gcc_make=-shared} ${LDFLAGS} BRLTTY_OPTIONS_LD2CC([${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>}]) -o"
+ else
+ brltty_cv_prog_mklib="\$(LD) ${brltty_mklib_ld_make} ${brltty_mklib_ld_options+${brltty_mklib_ld_options} <name>} -o"
+ fi])
+--- a/Bindings/OCaml/Makefile.in
++++ b/Bindings/OCaml/Makefile.in
+@@ -55,13 +55,13 @@
+ all : $(OCAML_FILES)
+
+ $(OCAML_CLIBS) : brlapi_stubs.$O brlapi
+- $(OCAMLMKLIB) $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(API_LDFLAGS) -oc $(OCAML_LIB)_stubs brlapi_stubs.$O
+
+ $(OCAML_BCLIB) : $(OCAML_CLIBS) brlapi.cmo
+ $(OCAMLC) -a $(OCAMLMKLIB_FLAGS) -o $(OCAML_LIB).cma brlapi.cmo
+
+ $(OCAML_NCLIB) : $(OCAML_CLIBS) brlapi.cmx
+- $(OCAMLMKLIB) $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
++ $(OCAMLMKLIB) -ldopt "$(LDFLAGS)" $(OCAMLMKLIBOPT_FLAGS) -o $(OCAML_LIB) brlapi.cmx
+
+ brlapi.cmi: brlapi.mli
+ $(OCAMLC) -o $@ -c brlapi.mli
diff --git a/app-accessibility/brltty/files/brltty-5.2-major.patch b/app-accessibility/brltty/files/brltty-5.2-major.patch
new file mode 100644
index 000000000000..7c591b1cc0e9
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-major.patch
@@ -0,0 +1,59 @@
+Bug: https://bugs.gentoo.org/581130
+diff --git a/Programs/system_linux.c b/Programs/system_linux.c
+index c73bd39..ef7d807 100644
+--- a/Programs/system_linux.c
++++ b/Programs/system_linux.c
+@@ -25,6 +25,12 @@
+ #include <sys/ioctl.h>
+ #include <sys/stat.h>
+
++#ifdef MAJOR_IN_MKDEV
++#include <sys/mkdev.h>
++#elif defined MAJOR_IN_SYSMACROS
++#include <sys/sysmacros.h>
++#endif
++
+ #include "log.h"
+ #include "file.h"
+ #include "device.h"
+diff --git a/configure.ac b/configure.ac
+index 96305f7..dcae1e1 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -555,6 +555,8 @@ BRLTTY_ARG_DISABLE(
+ ])
+ AC_SUBST([install_messages])
+
++AC_HEADER_MAJOR
++
+ AC_CHECK_FUNC([wcslen], [AC_CHECK_HEADERS([wchar.h], [dnl
+ AC_CHECK_FUNCS([wcwidth])
+ ])])
+diff --git a/config.h.in b/config.h.in
+index 71341c6..ff201c2 100644
+--- a/config.h.in
++++ b/config.h.in
+@@ -457,2 +457,10 @@ extern "C" {
+
++/* Define to 1 if `major', `minor', and `makedev' are declared in <mkdev.h>.
++ */
++#undef MAJOR_IN_MKDEV
++
++/* Define to 1 if `major', `minor', and `makedev' are declared in
++ <sysmacros.h>. */
++#undef MAJOR_IN_SYSMACROS
++
+ /* Define this to be a string containing the path to the root of the Mikropuhe package. */
+diff --git a/Programs/brlapi_client.c b/Programs/brlapi_client.c
+index bd6497b..df63b30 100644
+--- a/Programs/brlapi_client.c
++++ b/Programs/brlapi_client.c
+@@ -32,2 +32,8 @@
+
++#ifdef MAJOR_IN_MKDEV
++#include <sys/mkdev.h>
++#elif defined MAJOR_IN_SYSMACROS
++#include <sys/sysmacros.h>
++#endif
++
+ #ifndef __MINGW32__
diff --git a/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch b/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
new file mode 100644
index 000000000000..95451dc98b77
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-respect-AR.patch
@@ -0,0 +1,12 @@
+diff -Naur brltty-5.2/Programs/Makefile.in brltty-5.2-new/Programs/Makefile.in
+--- brltty-5.2/Programs/Makefile.in 2014-11-06 07:28:41.000000000 -0800
++++ brltty-5.2-new/Programs/Makefile.in 2014-11-20 05:41:57.144219093 -0800
+@@ -434,7 +434,7 @@
+ [ ! -f lib.def ] || mv lib.def $(API_DEF)
+
+ $(API_ARC): $(API_CLIENT_OBJECTS)
+- ar rc $@ $(API_CLIENT_OBJECTS)
++ $(AR) rc $@ $(API_CLIENT_OBJECTS)
+ $(RANLIB) $@
+
+ brlapi_client.$O:
diff --git a/app-accessibility/brltty/files/brltty-5.2-udev.patch b/app-accessibility/brltty/files/brltty-5.2-udev.patch
new file mode 100644
index 000000000000..dbbc29897662
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty-5.2-udev.patch
@@ -0,0 +1,28 @@
+diff -Naur brltty-5.2/Autostart/Udev/udev.rules brltty-5.2-new/Autostart/Udev/udev.rules
+--- brltty-5.2/Autostart/Udev/udev.rules 2014-11-06 07:28:41.000000000 -0800
++++ brltty-5.2-new/Autostart/Udev/udev.rules 2014-11-20 05:28:44.404885312 -0800
+@@ -182,20 +182,22 @@
+ # FreedomScientific [Focus Blue]
+ ENV{PRODUCT}=="f4e/114/*", ENV{BRLTTY_BRAILLE_DRIVER}="fs", GOTO="brltty_usb_run"
+
++# Seika rules are commented out, because they conflict with USB-to-serial
++# converters.
+ # Device: 10C4:EA60
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge / myAVR mySmartUSB light
+ # BrailleMemo [Pocket]
+ # Seika [Braille Display]
+-ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea60/*", ENV{BRLTTY_BRAILLE_DRIVER}="mm,sk", GOTO="brltty_usb_run"
+
+ # Device: 10C4:EA80
+ # Generic Identifier
+ # Vendor: Cygnal Integrated Products, Inc.
+ # Product: CP210x UART Bridge
+ # Seika [Note Taker]
+-ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
++#ENV{PRODUCT}=="10c4/ea80/*", ENV{BRLTTY_BRAILLE_DRIVER}="sk", GOTO="brltty_usb_run"
+
+ # Device: 1148:0301
+ # BrailleMemo [Smart]
diff --git a/app-accessibility/brltty/files/brltty.rc b/app-accessibility/brltty/files/brltty.rc
new file mode 100644
index 000000000000..0bc6c6c5375b
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty.rc
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+command=/bin/brltty
+pidfile=/var/run/brltty.pid
+command_args="-P $pidfile -q"
+
+depend() {
+ before *
+ after clock
+}
diff --git a/app-accessibility/brltty/files/brltty.tmpfiles.conf b/app-accessibility/brltty/files/brltty.tmpfiles.conf
new file mode 100644
index 000000000000..18cc4021e33b
--- /dev/null
+++ b/app-accessibility/brltty/files/brltty.tmpfiles.conf
@@ -0,0 +1 @@
+d /run/brltty 0755 root root -