summaryrefslogtreecommitdiff
path: root/xfce-extra
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-18 12:04:39 +0100
commit2d01b3d133c0fbf17de8d7b47905585af88bd6e4 (patch)
treef74eb9a3d16ed25f8c15b825f4d28b759ae99a42 /xfce-extra
parent97bacba3ead078e5db8b87ab651a3ffa7d82f60f (diff)
gentoo auto-resync : 18:04:2024 - 12:04:39
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/Manifest.gzbin7716 -> 7720 bytes
-rw-r--r--xfce-extra/thunar-vcs-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.2.0-r1.ebuild50
3 files changed, 51 insertions, 0 deletions
diff --git a/xfce-extra/Manifest.gz b/xfce-extra/Manifest.gz
index 9ceed6533560..42bf3942f12e 100644
--- a/xfce-extra/Manifest.gz
+++ b/xfce-extra/Manifest.gz
Binary files differ
diff --git a/xfce-extra/thunar-vcs-plugin/Manifest b/xfce-extra/thunar-vcs-plugin/Manifest
index f89b5198b936..8567e2e69449 100644
--- a/xfce-extra/thunar-vcs-plugin/Manifest
+++ b/xfce-extra/thunar-vcs-plugin/Manifest
@@ -1,3 +1,4 @@
DIST thunar-vcs-plugin-0.2.0.tar.bz2 546608 BLAKE2B ccd0d057e358b321b6287284c25ee03c4252f5e120fcba9272139ebf0739ee7363e619da12f86e725abc70d4834451ec112386ba2b008b038c03571d26349f51 SHA512 c33f54caa2f27de6c8f9e5cb8368f7538ea82730f1364ad974b19017a25bc6a398c19dfe861b0d0133db08ee36e4e209c8d824ce07de0c2ae6da830aca9e7e68
+EBUILD thunar-vcs-plugin-0.2.0-r1.ebuild 1017 BLAKE2B 6eef4999d72949ec270df2f9386b7975985c2abbd3dadec373ba135ae9222ac41b8a282c8c818ff43336e7a9f9210337c753f370c07db7bd91ac0d8c2f5052d2 SHA512 b3da9d8f40919a230d682db742ca1b0a2976c60547473bbc00d9385b876043eb283468917ab92ff0eb700f4e7918fc26700288ff032bd206d5c69a36ce406635
EBUILD thunar-vcs-plugin-0.2.0.ebuild 1016 BLAKE2B c5fe0ac3fe6d1d4abc5c5853311c70c8d9851dc4b737488af6a9d4e69db4c9fe6fcffca762ccc5715882cde1da46baefecddd391cbecda652167975b4c1d563f SHA512 1725a2c89dfca909a880ee4b4a0d97f131090da5a175fd381e0938d5634bd06c7d3f8dd1192b163e6e2040cd8ccb81a504b10c216ff9f96cf1dfa84c443f7ba1
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.2.0-r1.ebuild b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..172f183a5c92
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.2.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Adds Subversion and GIT actions to the context menu of thunar"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+SRC_URI="https://archive.xfce.org/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="+git +subversion"
+
+RDEPEND=">=dev-libs/glib-2.32:2=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/exo-0.11.4:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/thunar-1.7:=
+ git? ( dev-vcs/git )
+ subversion? (
+ >=dev-libs/apr-0.9.7:=
+ >=dev-vcs/subversion-1.5:=
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable subversion)
+ $(use_enable git)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}