summaryrefslogtreecommitdiff
path: root/xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 13:42:19 +0100
commitbd8ca999980e9c0c9ae40a11789c858bb58769e3 (patch)
tree355d68a84921e04a81231e74fc062f229f76a733 /xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild
parentb3f2504c1d05b5999b74b2135860fc721e3adf68 (diff)
gentoo auto-resync : 15:07:2022 - 13:42:19
Diffstat (limited to 'xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild')
-rw-r--r--xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild b/xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild
new file mode 100644
index 000000000000..f725a7560151
--- /dev/null
+++ b/xfce-extra/xfdashboard/xfdashboard-0.9.91.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Maybe a GNOME shell like dashboard for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfdashboard/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38:2
+ >=x11-libs/gtk+-3.2:3
+ >=media-libs/clutter-1.12:1.0=[gtk]
+ >=x11-libs/libwnck-3:3=
+ x11-libs/libX11:=
+ x11-libs/libXcomposite:=
+ x11-libs/libXdamage:=
+ x11-libs/libXinerama:=
+ >=xfce-base/garcon-0.2.0:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfconf-4.14:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}