summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-14 13:40:00 +0100
commit3e627c1432765cb6a32877e73f985e8bfb5102ce (patch)
treee4d7919d9e1ca0a54c1a3758c86555d6e9121956 /xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
parent4a30f472147c2d8642bd558b78fcfce7b6a9c6b9 (diff)
gentoo auto-resync : 14:07:2022 - 13:40:00
Diffstat (limited to 'xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
new file mode 100644
index 000000000000..cf690e000d06
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+DEPEND="
+ gnome-base/librsvg
+ x11-libs/gtk+:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.3
+ xfce-base/garcon:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( x11-libs/libnotify )
+"
+RDEPEND="
+ ${DEPEND}
+ x11-apps/setxkbmap
+ >=xfce-base/xfce4-settings-4.11
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}