summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild')
-rw-r--r--xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild
new file mode 100644
index 000000000000..5956ffea6e03
--- /dev/null
+++ b/xfce-extra/xfce4-smartbookmark-plugin/xfce4-smartbookmark-plugin-0.4.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Smart bookmark plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-smartbookmark-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+COMMON_DEPEND="x11-libs/gtk+:2=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/xfce4-panel-4.10:="
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/exo-0.8"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+src_prepare() {
+ sed -i -e '/bugs/s:debian:gentoo:' src/smartbookmark.c || die
+ xfconf_src_prepare
+}