summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-sensors-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /xfce-extra/xfce4-sensors-plugin
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'xfce-extra/xfce4-sensors-plugin')
-rw-r--r--xfce-extra/xfce4-sensors-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.3.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/Manifest b/xfce-extra/xfce4-sensors-plugin/Manifest
index 3f1e868d2748..c7626f35e12f 100644
--- a/xfce-extra/xfce4-sensors-plugin/Manifest
+++ b/xfce-extra/xfce4-sensors-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-sensors-plugin-1.4.2.tar.bz2 508525 BLAKE2B 619bfbc8d4453697cee2c5d5a669edee1a455e899a50229c77bf1b41661e06d7811a09e446e84e5cf62b9c24d7244f3eec74eb14fe7ccc4bcf49a25b14df9d18 SHA512 0b036ca6b040f1f97576917c944e19b9b5803c4e98f1d21435c0a5598701c9bff053e014f03edd09dbb9232e5c932c014719999a0e972e5e3db8330665c0217c
+DIST xfce4-sensors-plugin-1.4.3.tar.bz2 508993 BLAKE2B 4e857c2b31b6dc1d9e1f5adeb0b34c1f68c0e3386c7211533c5ffdfddddfc307fd16b0a55b6f8697aab87c62e143f3e8795c1a7ba36c3cfd18e92b56e316c7f0 SHA512 2cb91afaf740db5bbbb8451cfa0540ee979671e6a1a640ad61dfeb41328c057bc16fa668e9d536595ef460bfbd41617e8b3d27f63e02324e9764543fa6a0b2b5
EBUILD xfce4-sensors-plugin-1.4.2.ebuild 1513 BLAKE2B 36e20ad2bdad000e559efd129257a4eee807ad0b6e0e606c784f06595d65989dea709dbdf5da462657580ac67c6b33de06cfffd101a0b1388bb6b70b0b54168b SHA512 1c7faeb65208648703479833efe530f2607d6ca304e4f9dbf21edb23140f3eb28b6be1c814722810f6a9c773b493a596c58b402b7320acc9db887ac3437a33b3
+EBUILD xfce4-sensors-plugin-1.4.3.ebuild 1515 BLAKE2B 3729100f55bd08fd34d6d7083e48cb0caa580fd4d76c3269f9ab2dcddb38696e3ba1ef10fe442ec4a9fe20e0a9b399f3acbc66a83a9f175f98d93ff22a672199 SHA512 7323bcca9133a2b866b73097b1bf0fd75d497dc286b6f72b27b1a8625ff4d25b47a41071d071879621f3ce38022122db62a41d26fdb38534a75ba1b556b4fdb8
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.3.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.3.ebuild
new file mode 100644
index 000000000000..04045ee3f7fb
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.3.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for acpi, lm-sensors and hddtemp sensors"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+acpi hddtemp libnotify lm-sensors video_cards_nvidia"
+
+REQUIRED_USE="|| ( hddtemp lm-sensors acpi )"
+
+RDEPEND=">=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.12:=
+ hddtemp? (
+ app-admin/hddtemp
+ || (
+ net-analyzer/openbsd-netcat
+ net-analyzer/netcat
+ )
+ )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ lm-sensors? ( >=sys-apps/lm-sensors-3.1.0:= )
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers[tools,static-libs] )"
+DEPEND=${RDEPEND}
+
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable lm-sensors libsensors)
+ $(use_enable hddtemp)
+ $(use_enable hddtemp netcat)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(use_enable libnotify notification)
+ --disable-pathchecks
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}