summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-playercontrol-plugin/xfce4-playercontrol-plugin-0.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/xfce4-playercontrol-plugin/xfce4-playercontrol-plugin-0.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/xfce4-playercontrol-plugin/xfce4-playercontrol-plugin-0.3.0.ebuild')
-rw-r--r--xfce-extra/xfce4-playercontrol-plugin/xfce4-playercontrol-plugin-0.3.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-playercontrol-plugin/xfce4-playercontrol-plugin-0.3.0.ebuild b/xfce-extra/xfce4-playercontrol-plugin/xfce4-playercontrol-plugin-0.3.0.ebuild
new file mode 100644
index 000000000000..4cf63ad35f3e
--- /dev/null
+++ b/xfce-extra/xfce4-playercontrol-plugin/xfce4-playercontrol-plugin-0.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="Audacious and MPD panel plugins"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-xmms-plugin"
+SRC_URI="http://www.bilimfeneri.gen.tr/ilgar/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="audacious mpd"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/pango
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8
+ mpd? ( >=media-libs/libmpd-0.12 )
+ audacious? ( >=media-sound/audacious-1.4 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-undeclared_XfceRc.patch )
+
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --disable-static
+ --disable-xmms
+ $(use_enable audacious)
+ $(use_enable mpd)
+ )
+
+ DOCS=( AUTHORS ChangeLog README README.developers )
+}
+
+src_prepare() {
+ echo panel-plugin/mpc.c > po/POTFILES.skip
+ echo panel-plugin/popupmenu.c >> po/POTFILES.skip
+ xfconf_src_prepare
+}