summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r2.ebuild
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r2.ebuild')
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r2.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r2.ebuild
new file mode 100644
index 000000000000..1b1a4a0bca9f
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.7.0-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2.28:2
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=[gtk2(+)]
+ >=xfce-base/libxfce4ui-4.8:=[gtk2(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.8:=[gtk2(+)]
+ >=xfce-base/xfconf-4.8:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}