summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-panel-profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-05 21:37:49 +0100
commit50c291a3ace58006f8fa9cf44a36f6e42bff2b54 (patch)
tree6d245677a5bb2d38b74c141346e35465540e9b7f /xfce-extra/xfce4-panel-profiles
parent53623081143d09702d8f3d7224e9da8c5f681c3b (diff)
gentoo auto-resync : 05:06:2023 - 21:37:49
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest2
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild53
2 files changed, 55 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index eed1b63e3b3c..06da29beb0df 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-panel-profiles-1.0.13.tar.bz2 86671 BLAKE2B 0bf2d39aa2d7d21a99a9a7245e5de9e717b628f0eded2736db70cc87c4f6e1e1d10aecdc6586c43c6355747e68a2ceb1920d5309bf38ede07c1167c590dc116f SHA512 648324e5dd95ab0a513829d7d816e2113ae677d9ad6ac9b01d73c6b4105b54d5e773150d5440ad35a37b4dc75478f40a24e0223decf940f3cf658241547ce75a
+DIST xfce4-panel-profiles-1.0.14.tar.bz2 101521 BLAKE2B 197ebba356e8d7661779531147b08454762a9b61beebd2323bc9e88b26381952c2caa58c6fb110680a5038fc19422852722d72dfde09addb68ec9424ecf16a23 SHA512 e316e9d4f0d27b16ce83a50adfe1a3fe2102b7f5c3ed9e9ceebf5968e265064b4d4ade1e0dbd84180758a9c1fa72d8df1fb4d06a631d07956ea8add0f66da984
EBUILD xfce4-panel-profiles-1.0.13.ebuild 1077 BLAKE2B edcce49026d3566653cc0e2d3ee31ec8f42561c1a262a349468b1d3f95a4cd7037dafccd50f7554a0d3cfc6c98ba067a35335590a90d7c0a332b504aad091c85 SHA512 46041023ddc9407eabeec8eb6b2f8a278da3fffe610fb8f591f6a5ab8b2268ffc2b388d0188b36dd23387edad7875d619fb2938fcc9a5e393fba30f54c3f7b2e
+EBUILD xfce4-panel-profiles-1.0.14.ebuild 1078 BLAKE2B 8249b7f3fa44243104fe9028b52bd1a0a55c0debc5c725226a0221ca2392e428c4838cd648a462b2950a8d16e68732957305f5267d6898cf4dbbd8290f3753fd SHA512 fe266da58f82dd55e054a99749617fefd8fe61c931871ebb759656e2a99719da557795cfa5aff0874fbd8241d8212d35e8efe7d1b7747f6660069ffa3dcf191a
MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
new file mode 100644
index 000000000000..f7ba0bc11386
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.14.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-panel-profiles/start
+ https://gitlab.xfce.org/apps/xfce4-panel-profiles/
+"
+SRC_URI="
+ https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${BDEPEND}
+ dev-libs/gobject-introspection
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ xfce-base/libxfce4ui[introspection]
+ xfce-base/xfce4-panel
+"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --python="${EPYTHON}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}