summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-panel-profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /xfce-extra/xfce4-panel-profiles
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest3
-rw-r--r--xfce-extra/xfce4-panel-profiles/metadata.xml8
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.8.ebuild36
3 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
new file mode 100644
index 000000000000..32ea52a15e8e
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -0,0 +1,3 @@
+DIST xfce4-panel-profiles-1.0.8.tar.bz2 40074 BLAKE2B 620e74a6c5a7316e82bda0ad217abc9868685ee9fee6857c4e8aa35002f78f938a754ce709e56466ad648ae4637144d3e90d909e5d9e6865c5e519db75c4da8e SHA512 2d7980a79250414cc4611ccf573c2a3ee5eb510cf3ef6c32035ba23197eee1fded2e158cb50714dd935070916b07b3f33db02570f3d46a598144b4a2d3979ff4
+EBUILD xfce4-panel-profiles-1.0.8.ebuild 908 BLAKE2B 5a73e51fea7d81fe30596d24c581dcd398a6b3809795b9ad29c4eabb356e3129cb742ddb10be29e0177d74f55f379194804ce866b04a8ce5e49a9ca30be56fb5 SHA512 9dbc1e5a959c1c7c3ac78bbfa3056f594be0240ad63bfc73b77eb08b7e1140420050a4afdcd8a51df1764c256fe3ee630dfff012a808383481a7a621b4985e75
+MISC metadata.xml 240 BLAKE2B f2b1d74c53614dbfcc23494ddeeeb4726d3ebe22d0145658ac68fceb568b6f5f1d97cc59f17cd5a301e3cdabff03a4e5c48ba32a68577e0029c72eb348f13afe SHA512 c2cb083e77cc0a28c202c630546b0db2f37996e3125f0a6c9ead8ae5f819f910371ba237c59c09b7b7b83c417f1514f0e89a9b1c784bd282f60c377b0db020cd
diff --git a/xfce-extra/xfce4-panel-profiles/metadata.xml b/xfce-extra/xfce4-panel-profiles/metadata.xml
new file mode 100644
index 000000000000..04cf7b5c1393
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.8.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.8.ebuild
new file mode 100644
index 000000000000..b6c2521982cc
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit python-single-r1
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
+SRC_URI="https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ xfce-base/xfce4-panel"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure --prefix="${EPREFIX}/usr" --python="${EPYTHON}" || die
+}
+
+src_install() {
+ default
+
+ # the default gets it right
+ rm -r "${ED}"/usr/share/doc/xfce4-panel-profiles || die
+}