summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-notes-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-18 18:31:43 +0000
commitcd0d9000770337b445051f1852fe3971ceb7a6e2 (patch)
tree49c82dbb14c2d960e04e7482bdefe6ed2d53a173 /xfce-extra/xfce4-notes-plugin
parent12c505f7fcc9ddc89e96ed178df05aceec162d92 (diff)
gentoo auto-resync : 18:03:2023 - 18:31:42
Diffstat (limited to 'xfce-extra/xfce4-notes-plugin')
-rw-r--r--xfce-extra/xfce4-notes-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notes-plugin/Manifest b/xfce-extra/xfce4-notes-plugin/Manifest
index deff80c9aa91..5b47a40ebf63 100644
--- a/xfce-extra/xfce4-notes-plugin/Manifest
+++ b/xfce-extra/xfce4-notes-plugin/Manifest
@@ -1,3 +1,5 @@
+DIST xfce4-notes-plugin-1.10.0.tar.bz2 492901 BLAKE2B 4b4724bf767e61b7c73ddeda71d4097751786d60335947d233e78fb8967ee9302d55a7cc259be4dbf2f8122d33a108769fdccdaf77f8fd4b50789196794e0b91 SHA512 4c050a95f879f0ba5e28662853ab764a14fbcef513e037bfdef1e3cae91b504d0c55eb0b533098589cf568c8e6e6e3ec2dec0841eb54c99c50105f6fff55a447
DIST xfce4-notes-plugin-1.9.0.tar.bz2 502606 BLAKE2B 2b1b2dd97301ab57363aeaa8a373c62a9e9c14bdc1eb7dd6355bb096728b05e5bee08ce8a5922c2a93f1c2b7fa7197f8aa3fb0c2a96d5eb71a7002c22eb8d13c SHA512 32ee410fa9d4dff4f73a844ac53024c39a884b48cee32faf14c1ed75200f912bd4e51a1fe3305deea9ec98a617b63a65e271437b09cb9b664498746a8095f4a1
+EBUILD xfce4-notes-plugin-1.10.0.ebuild 935 BLAKE2B c725fb0ed0ab455259666100ccffe771e5dd8427a44a2d982b93309f769dbffbccd8a12957e03fb1564c76fee398c95cda3960e5d1799328dd5b1006400565c9 SHA512 e010c7ad38526fc3063249fc4f2f59a5c33fc934b661b76ae188a2b1e494b3f7ff0315293c997b095485635e86ea7e367d59e38bd646e1e53958bb50ecd615a5
EBUILD xfce4-notes-plugin-1.9.0.ebuild 873 BLAKE2B af3182161ffcefc171cd81dacb155f3a035e214e9c6e6d67bd267c60d6cc0e6f2c9569357c6b4d07a0a57ac55ddf310cc5cbe2943da3fbf3a0f54371f8c47e1d SHA512 4c273af29aa2bbb5eaf9ecab70f8a031b6f0d64b12a794e5370f678b25995bdd5df8dfd84f5a8bcc2ba8ed5c881a236331d049a04a43609d2dcd0f87a9e5a007
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild
new file mode 100644
index 000000000000..2caea09923fc
--- /dev/null
+++ b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 panel sticky notes plugin"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-notes-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-notes-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}