summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-21 06:01:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-21 06:01:43 +0100
commit0cdd46ad5d0cd7ede78815175764fdf76649d46e (patch)
tree8ece938369c65a410a308f3f05ebb9d2a7fdc008 /xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild
parentd33b3cf6cff9fdbfc8362bf854c3c34b2c28d518 (diff)
gentoo auto-resync : 21:04:2023 - 06:01:43
Diffstat (limited to 'xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild')
-rw-r--r--xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild b/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild
new file mode 100644
index 000000000000..ab77e47112b3
--- /dev/null
+++ b/xfce-extra/xfce4-mount-plugin/xfce4-mount-plugin-1.1.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="An mount plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-mount-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-mount-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}