summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3.ebuild')
-rw-r--r--xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3.ebuild b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3.ebuild
new file mode 100644
index 000000000000..2c27674053ee
--- /dev/null
+++ b/xfce-extra/xfce4-hdaps/xfce4-hdaps-1.0.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Show the status of the IBM Hard Drive Active Protection System"
+HOMEPAGE="http://michael.orlitzky.com/code/xfce4-hdaps.xhtml"
+SRC_URI="http://michael.orlitzky.com/code/releases/${P}.tar.xz"
+
+LICENSE="AGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+DEPEND=">=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4ui-4.14
+ >=xfce-base/libxfce4util-4.14
+ >=xfce-base/xfce4-panel-4.14:="
+RDEPEND="${DEPEND}
+ app-laptop/hdapsd
+ app-laptop/tp_smapi"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}