summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.1.1.ebuild
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.1.1.ebuild')
-rw-r--r--xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.1.1.ebuild b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.1.1.ebuild
new file mode 100644
index 000000000000..e2a9c9ae140e
--- /dev/null
+++ b/xfce-extra/xfce4-genmon-plugin/xfce4-genmon-plugin-4.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Cyclically spawned executable output on the panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-genmon-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}