summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.0.ebuild')
-rw-r--r--xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.0.ebuild b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.0.ebuild
new file mode 100644
index 000000000000..facc684bd9cc
--- /dev/null
+++ b/xfce-extra/xfce4-fsguard-plugin/xfce4-fsguard-plugin-1.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="A filesystem guard plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-fsguard-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}