summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-clipman-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-29 17:41:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-29 17:41:08 +0000
commit0c1bebc4027c639909ad0a840068b649b6be4b95 (patch)
tree454e0d892bb070962971634b5fbdfe617cba1dd1 /xfce-extra/xfce4-clipman-plugin
parent080a6ad2c3759083c02506e1348b689f2194d4eb (diff)
gentoo auto-resync : 29:02:2024 - 17:41:08
Diffstat (limited to 'xfce-extra/xfce4-clipman-plugin')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild75
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index 9fa65a153fad..30b63a9b4a58 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-clipman-plugin-1.6.5.tar.bz2 483621 BLAKE2B 0c13126a17e0fc668945b479dab3919b3f6e03a0ad378050041f40ddc4d0f138ffec128be779275eac637daf42352de4ac143d43d26cb8f40ac4d754d8ee70fb SHA512 b0ae4a3928590346dd0f9786959c138f7e9cc03afa974eee558890fcd2b96c019bd4be67f7c231cac802fb6356c64b1e0394ef327aae6256fc433ced245fdff9
+DIST xfce4-clipman-plugin-1.6.6.tar.bz2 487832 BLAKE2B 4d27c06c71c978680a2785db67262196293f1692fd82ba9cfdc2810b021dc83d8778243801e0766741e8f194a5aaa0573d5548443f6c3bfc9f7b970d7f102446 SHA512 4f6bb8f56111903af576d06ce5883e8ada2cb3ea377e09a79d2c5fb6f37743dac621649465a573a8a29a1fb884e7608a53dd6486eada23c7f8ee6401237988af
EBUILD xfce4-clipman-plugin-1.6.5.ebuild 1522 BLAKE2B 9ed95badbc096a84c429535489cb66a6a2d5f4b59eb0d88e029721818619fba01c4d1a1f1ea03f5c8d01d1d225cae4f13f8f759d10f3b2ba3ddc598853ee694e SHA512 d07ac83ab0832f657f41f4ad0b91ab4b87c9d76a3d2d57003b2837c24c46bfad9877c99be31b4a473ffac3fb56ad6eb505780d7a6e17d4a96d2eccbfde2da729
+EBUILD xfce4-clipman-plugin-1.6.6.ebuild 1397 BLAKE2B b7cfa04d32e5f6f4cdcbf6e630dd41f3f06f7480143a4e0256402ccc5264818c1a6457d51f1c7e7f0900513598dbc4aa4a65af955325eaa55315849bb1869eee SHA512 048873a4917fcaafc334b7f5a52606ad6f706ce4e8a8af77f42753a40c087b2dffec64c8aba36f6a1d0ec93b461d5a966195e63dfa5da60626b1c22fb2daf567
MISC metadata.xml 345 BLAKE2B 2a84642f72b32862062e911bc3d9495d77cde305206e3ba0d0bc82c792450506696d02e45b59d5035278bf53061016c72de278586e7669d53899c4d3c86585fe SHA512 0dbb04321b8dedc5bdfd3e7714cdbb3021ec1c866fcc61613081282c32316af6598e1516b629c6c6560a509abb0e6f378c0089dca1425b6c82ab796d5875a693
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild
new file mode 100644
index 000000000000..1e9a3da9e982
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-clipman-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-clipman-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X qrcode wayland"
+
+DEPEND="
+ >=dev-libs/glib-2.60.0
+ >=x11-libs/gtk+-3.22.29:3[wayland?,X?]
+ >=xfce-base/libxfce4ui-4.14.0:=
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ >=xfce-base/xfconf-4.14.0:=
+ X? (
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libXtst-1.0.0
+ )
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )
+ wayland? (
+ >=dev-libs/wayland-1.15.0
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ X? (
+ >=x11-base/xorg-proto-7.0.0
+ )
+ wayland? (
+ >=dev-util/wayland-scanner-1.15.0
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+
+ $(use_enable wayland)
+ $(use_enable X x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}