summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-calculator-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-20 05:59:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-20 05:59:19 +0100
commitdcf9ac80d0667a18496506842a8903ba5dab2fc7 (patch)
tree2b00642cd6bdbd7de71159350f01b424ffc37420 /xfce-extra/xfce4-calculator-plugin
parentf7e94be7540157809ed892278b6765c368a5a912 (diff)
gentoo auto-resync : 20:04:2023 - 05:59:19
Diffstat (limited to 'xfce-extra/xfce4-calculator-plugin')
-rw-r--r--xfce-extra/xfce4-calculator-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.2.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-calculator-plugin/Manifest b/xfce-extra/xfce4-calculator-plugin/Manifest
index 965a58945da0..518958ec19aa 100644
--- a/xfce-extra/xfce4-calculator-plugin/Manifest
+++ b/xfce-extra/xfce4-calculator-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-calculator-plugin-0.7.1.tar.bz2 402401 BLAKE2B feadd3401f5e7b3bd1bc9277e04d63329fa0d35583c6af959fa350c6622012b4089fd1143dd8f7e987cde8a6b313fba75cfba751e2afb6bcba43d9787d17784b SHA512 05544e5f0e293fe44ae35b3e11a2e6fac8df13743649d0702c01c6a4b2df0557f8f9712acef6bd51aaa65f5542234a6a649017bf2fe2a6d2860ae2e534e7cff2
+DIST xfce4-calculator-plugin-0.7.2.tar.bz2 422611 BLAKE2B 72bc2e8414b4f638299d42d8e3cd808949c966e40e96823ef5d47ba66e915429a66c7ab45acdda1a930383bc7cae63c2323e05ee8f9a5748c7f0e6d8f58b63e0 SHA512 98fa51ff0afbb09e3066f629113f6a584c5afd9228c87ee67afd7a56b065060ece16ee646ec6a2c685907a0d9733cba19cbf25bc034e009a013af2122155cc2c
EBUILD xfce4-calculator-plugin-0.7.1.ebuild 785 BLAKE2B 8c47dbf9344935cb2823299b22c534390ca74f5de2ed4d22fb93a03ef55136d60f26f8d8402af56d8f3fb18ebfca65868d3bad13ab1d972ddc50a6a674213ad8 SHA512 07501a338dbd6019302fd41ef3dc6a4e23ba35fe8a463bbc792508b7a828ca50ee35b193ff7da5ae826af20d2693359493fc362c8a379ee2d71239ba7e8f26a1
+EBUILD xfce4-calculator-plugin-0.7.2.ebuild 894 BLAKE2B 4b302a2ad3df5c5fdbdf4ab896cb6dd421056dcad728850cf16416a8789f604fe875ebed75cf0d9a1bb67e9d449589b6011e2feb602782561659d922d74fc9f0 SHA512 f6ed29e0929888acb2dbe4f3ffd0bc4506d5d659a04fa02a1b5d00abdd6090d0247a14f00dd551225a93822eb38be6bf672ea3219c844a1bc3665b6ee51bd3d7
MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
diff --git a/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.2.ebuild b/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.2.ebuild
new file mode 100644
index 000000000000..14de8bbbdf6a
--- /dev/null
+++ b/xfce-extra/xfce4-calculator-plugin/xfce4-calculator-plugin-0.7.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A calculator plugin for the Xfce4 panel"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-calculator-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-calculator-plugin/
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0
+ x11-libs/libX11
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.12.0:=
+ >=xfce-base/libxfce4util-4.12.0:=
+ >=xfce-base/xfce4-panel-4.12.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}