summaryrefslogtreecommitdiff
path: root/xfce-extra/thunar-volman/thunar-volman-0.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /xfce-extra/thunar-volman/thunar-volman-0.9.3.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'xfce-extra/thunar-volman/thunar-volman-0.9.3.ebuild')
-rw-r--r--xfce-extra/thunar-volman/thunar-volman-0.9.3.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/xfce-extra/thunar-volman/thunar-volman-0.9.3.ebuild b/xfce-extra/thunar-volman/thunar-volman-0.9.3.ebuild
new file mode 100644
index 000000000000..07219cde44df
--- /dev/null
+++ b/xfce-extra/thunar-volman/thunar-volman-0.9.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+# CC for tvm-burn-cd.svg
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libnotify"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30:=
+ virtual/libgudev:=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/udev
+ >=xfce-base/thunar-1.6[udisks]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}