summaryrefslogtreecommitdiff
path: root/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild')
-rw-r--r--xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild b/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild
new file mode 100644
index 000000000000..0fcf5ac16a0c
--- /dev/null
+++ b/xfce-extra/eatmonkey/eatmonkey-0.1.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A download manager that works exclusively with aria2"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/eatmonkey"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
+ dev-libs/libunique:1
+ >=xfce-base/libxfce4util-4.8
+ >=net-libs/libsoup-2.26:2.4"
+RDEPEND="${COMMON_DEPEND}
+ >=net-misc/aria2-1.9.0[bittorrent,xmlrpc]
+ dev-lang/ruby
+ dev-ruby/ruby-glib2
+ dev-ruby/ruby-gtk2"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-syntax.patch )
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+src_prepare() {
+ sed -i -e 's:/usr/local:/usr:' src/eat{monkey,manager.rb} || die
+ xfconf_src_prepare
+}