summaryrefslogtreecommitdiff
path: root/xfce-base/libxfce4util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /xfce-base/libxfce4util
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'xfce-base/libxfce4util')
-rw-r--r--xfce-base/libxfce4util/Manifest2
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 5661062ec618..e838534ab9e8 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,3 +1,5 @@
DIST libxfce4util-4.13.2.tar.bz2 509280 BLAKE2B 40f1fb95abff4857e976dd5f3ae8c8ad5e66e2c1c49723735e85124db71d30f204525cd74baf22e31bf405718f378b0c9ac37ec4189e1f4b9941d0eb6fc141ce SHA512 3bbb718f3a6d2213c86695b3f99d1e67c859ce635e5d066b18745d2ee57c0b2eea468b61079d8e2514c2d8f5fa847539d236ec0ed3fd17fecd9d1b36dc3595c4
+DIST libxfce4util-4.13.3.tar.bz2 511277 BLAKE2B 0815808166bc488cfa3636a18c9486fd1b3a81376766a77eef80ee24274bb290b9bece5e7786f7e412154f201bef251ce90d350c9e69db79bb893fd9081d2dac SHA512 e06bf58d46c5c3c6964a17ca8d998bd8e78bb61577ddcd855680878a890912a167212a2b4e3b347f41f84d2983e71fd1d76716db9c4a88a1d4f45a0f5aaf5e51
EBUILD libxfce4util-4.13.2.ebuild 1041 BLAKE2B 8b023aafc1f8ecdc8b28fd04ba157b8aba8acb5acfa9c632ad0430a388860385a4b94d6288ee11a85236f89eb0468dbb6317ba8378dbf0e5700d7dfb2e5c787a SHA512 91cf34ea64d24c21d603eef18e95c8d2164aaa9825fc3a2056cce5edb40564fa796e2975374f9a2c78ec97b6d180c5b6573ab23e9f895990a437e258ef9fea52
+EBUILD libxfce4util-4.13.3.ebuild 1048 BLAKE2B 397d348fc9cd6c1442530d58523f66d6c597ea8dea4287d0abf854ec803d717bc2262df1c715fdfb1f1e7a4a45504e3242c0ba3ef721d40fb30383ded56aaf39 SHA512 2f60d797b1bc0d8f76331b71a2889b4bdfac91572d166d48f9e91f4d175311fcb92937f05fd9e7c5a51915c15d9812776c45f773e10f3fd3203b704cc2be1622
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild b/xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild
new file mode 100644
index 000000000000..c83583139dad
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.13.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ vala? ( $(vala_depend) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}