summaryrefslogtreecommitdiff
path: root/xfce-base/libxfce4util/libxfce4util-4.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-base/libxfce4util/libxfce4util-4.13.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-base/libxfce4util/libxfce4util-4.13.1.ebuild')
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.13.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/libxfce4util-4.13.1.ebuild b/xfce-base/libxfce4util/libxfce4util-4.13.1.ebuild
new file mode 100644
index 000000000000..db183b019100
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.13.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection"
+
+RDEPEND=">=dev-libs/glib-2.30:=
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}