summaryrefslogtreecommitdiff
path: root/x11-wm/xpra/xpra-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-14 22:02:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-14 22:02:07 +0100
commit78db24b58a7f75bf18548cbf5c3b210f2f33f2f4 (patch)
tree53f180d30387a94fd028e0c5a10635621ebeb98f /x11-wm/xpra/xpra-9999.ebuild
parent153fd195574cc30040446316bb666af0e58d985f (diff)
gentoo auto-resync : 14:05:2023 - 22:02:07
Diffstat (limited to 'x11-wm/xpra/xpra-9999.ebuild')
-rw-r--r--x11-wm/xpra/xpra-9999.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/x11-wm/xpra/xpra-9999.ebuild b/x11-wm/xpra/xpra-9999.ebuild
index 08e2503c90e1..c4e11b241ef1 100644
--- a/x11-wm/xpra/xpra-9999.ebuild
+++ b/x11-wm/xpra/xpra-9999.ebuild
@@ -21,16 +21,17 @@ DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based o
HOMEPAGE="https://xpra.org/"
LICENSE="GPL-2 BSD"
SLOT="0"
-IUSE="brotli +client +clipboard csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal opengl pillow pinentry pulseaudio +server sound systemd test udev vpx webcam webp xdg xinerama"
+IUSE="brotli +client +clipboard crypt csc cups dbus doc ffmpeg jpeg html ibus +lz4 lzo minimal oauth opengl pillow pinentry pulseaudio +server sound systemd test udev vpx webcam webp xdg xinerama"
REQUIRED_USE="${PYTHON_REQUIRED_USE}
|| ( client server )
cups? ( dbus )
+ oauth? ( server )
opengl? ( client )
- test? ( client clipboard dbus html server sound xdg xinerama )
+ test? ( client clipboard crypt dbus html server sound xdg xinerama )
"
-TDEPEND="
+TEST_DEPEND="
$(python_gen_cond_dep '
dev-python/netifaces[${PYTHON_USEDEP}]
dev-python/pillow[jpeg?,${PYTHON_USEDEP}]
@@ -78,14 +79,14 @@ DEPEND="
"
RDEPEND="
${DEPEND}
- ${TDEPEND}
+ ${TEST_DEPEND}
$(python_gen_cond_dep '
+ crypt? ( dev-python/cryptography[${PYTHON_USEDEP}] )
cups? ( dev-python/pycups[${PYTHON_USEDEP}] )
lz4? ( dev-python/lz4[${PYTHON_USEDEP}] )
lzo? ( >=dev-python/python-lzo-0.7.0[${PYTHON_USEDEP}] )
- opengl? (
- client? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
- )
+ oauth? ( dev-python/oauthlib[${PYTHON_USEDEP}] )
+ opengl? ( dev-python/pyopengl_accelerate[${PYTHON_USEDEP}] )
webcam? (
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pyinotify[${PYTHON_USEDEP}]
@@ -101,7 +102,7 @@ RDEPEND="
udev? ( virtual/udev )
"
DEPEND+="
- test? ( ${TDEPEND} )
+ test? ( ${TEST_DEPEND} )
"
BDEPEND="
$(python_gen_cond_dep '
@@ -114,9 +115,9 @@ BDEPEND="
RESTRICT="!test? ( test )"
PATCHES=(
- "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
- "${FILESDIR}"/${PN}-4.3-no-service.patch
+ "${FILESDIR}"/${PN}-4.5-no-service.patch
"${FILESDIR}"/${PN}-9999-xdummy.patch
+ "${FILESDIR}"/${PN}-9999-tests.patch
)
python_prepare_all() {
@@ -143,6 +144,7 @@ python_configure_all() {
DISTUTILS_ARGS=(
--without-PIC
--without-Xdummy
+ $(use_with sound audio)
$(use_with client)
$(use_with clipboard)
$(use_with csc csc_swscale)
@@ -164,7 +166,6 @@ python_configure_all() {
$(use_with opengl)
$(use_with server shadow)
$(use_with server)
- $(use_with sound)
--with-strict
$(use_with vpx)
--with-warn