summaryrefslogtreecommitdiff
path: root/x11-wm/wmfs/wmfs-20180520.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /x11-wm/wmfs/wmfs-20180520.ebuild
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'x11-wm/wmfs/wmfs-20180520.ebuild')
-rw-r--r--x11-wm/wmfs/wmfs-20180520.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-wm/wmfs/wmfs-20180520.ebuild b/x11-wm/wmfs/wmfs-20180520.ebuild
new file mode 100644
index 000000000000..f01f6ce2129b
--- /dev/null
+++ b/x11-wm/wmfs/wmfs-20180520.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Window Manager From Scratch, A tiling window manager highly configurable"
+HOMEPAGE="https://github.com/xorg62/wmfs"
+SRC_URI="https://dev.gentoo.org/~jer/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+imlib2 +xinerama"
+
+RDEPEND="
+ media-libs/freetype
+ media-libs/imlib2[X]
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-99999999-Debian.patch
+ "${FILESDIR}"/${PN}-99999999-desktop.patch
+ "${FILESDIR}"/${PN}-99999999-fno-common.patch
+ "${FILESDIR}"/${PN}-99999999-strncat.patch
+)
+DOCS=(
+ README
+ scripts/keybind_help.sh
+ scripts/status.sh
+)
+
+src_configure() {
+ tc-export CC
+ # not autotools based
+ local ECHO
+ for ECHO in echo ''; do
+ ${ECHO} sh configure \
+ $(usex xinerama '' --without-xinerama) \
+ $(usex imlib2 '' --without-imlib2) \
+ --prefix /usr \
+ --man-prefix /usr/share/man \
+ --xdg-config-dir /etc/xdg \
+ || die
+ done
+}