summaryrefslogtreecommitdiff
path: root/x11-wm/windowlab/windowlab-1.40-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/windowlab/windowlab-1.40-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/windowlab/windowlab-1.40-r1.ebuild')
-rw-r--r--x11-wm/windowlab/windowlab-1.40-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-wm/windowlab/windowlab-1.40-r1.ebuild b/x11-wm/windowlab/windowlab-1.40-r1.ebuild
new file mode 100644
index 000000000000..28f22b9e18ac
--- /dev/null
+++ b/x11-wm/windowlab/windowlab-1.40-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="small and simple window manager of novel design"
+HOMEPAGE="http://www.nickgravgaard.com/windowlab/"
+SRC_URI="http://www.nickgravgaard.com/${PN}/${P}.tar"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+IUSE="truetype"
+
+RDEPEND="truetype? ( x11-libs/libXft )
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.34-fixed-font.patch"
+ "${FILESDIR}/${P}-gentoo.diff" )
+
+pkg_setup() {
+ if use truetype ; then
+ export DEFINES=-DXFT
+ export EXTRA_INC=$(pkg-config --cflags xft)
+ export EXTRA_LIBS=$(pkg-config --libs xft)
+ fi
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc CHANGELOG README TODO
+
+ exeinto /etc/X11/Sessions
+ cat <<- EOF > "${T}"/${PN}
+ #!/bin/sh
+ exec /usr/bin/${PN}
+ EOF
+ doexe "${T}"/${PN}
+}
+
+pkg_postinst() {
+ elog "${PN}'s menu config file has been changed from"
+ elog "/etc/X11/${PN}/menurc to /etc/X11/${PN}/${PN}.menurc"
+}