summaryrefslogtreecommitdiff
path: root/x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-31 20:30:04 +0000
commit4650985dd0e898b82e0d2ec225931297d4fadccf (patch)
treeeb0e8002cf3ebf1009110b6fec47fa90f873d824 /x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild
parent67f76a858f1ac826bd8a550d756d9ec6e340ed4f (diff)
gentoo resync : 31.01.2018
Diffstat (limited to 'x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild')
-rw-r--r--x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild b/x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild
new file mode 100644
index 000000000000..fbd35c2db101
--- /dev/null
+++ b/x11-wm/stumpwm-contrib/stumpwm-contrib-20180128.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit common-lisp-3
+
+DESCRIPTION="Extension Modules for StumpWM"
+HOMEPAGE="https://github.com/stumpwm/stumpwm-contrib/"
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-3 BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=x11-wm/stumpwm-1.0.0"
+
+CONTRIBCATEGORIES="media minor-mode modeline util"
+
+src_install() {
+ common-lisp-install-sources -t all ${CONTRIBCATEGORIES}
+ dobin util/stumpish/stumpish
+ dobin util/pinentry/stumpwm-pinentry
+ dodoc README.org
+}