summaryrefslogtreecommitdiff
path: root/x11-wm/openbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-06 03:21:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-06 03:21:28 +0100
commit681aad60df032a891dbbfc38f3ea4b404d6a8579 (patch)
treeda5eff2b4d9c8cca5f6df280543b43707f372f69 /x11-wm/openbox
parent2092ebe8b45cc45ad3357e2ccb2c37d5c1eaba2a (diff)
gentoo auto-resync : 06:08:2023 - 03:21:27
Diffstat (limited to 'x11-wm/openbox')
-rw-r--r--x11-wm/openbox/Manifest3
-rw-r--r--x11-wm/openbox/openbox-3.6.1-r7.ebuild126
-rw-r--r--x11-wm/openbox/openbox-9999.ebuild11
3 files changed, 136 insertions, 4 deletions
diff --git a/x11-wm/openbox/Manifest b/x11-wm/openbox/Manifest
index fc883877e0d0..b378ea4da30e 100644
--- a/x11-wm/openbox/Manifest
+++ b/x11-wm/openbox/Manifest
@@ -5,5 +5,6 @@ AUX openbox-3.6.1-py3-xdg.patch 4702 BLAKE2B 52e8f35626bf71a10327efe99d518994aec
DIST openbox-3.6.1.tar.gz 962665 BLAKE2B 1c0288137d7b02d443c384f970cd9a3f4d5d5585989917ac6ae8cf492e045dc086650c245907e168bc7b6d0ce701339854a5d94ad510823141cc78e28c1e13c5 SHA512 5e6f4a214005bea8b26bc8959fe5bb67356a387ddd317e014f43cb5b5bf263ec617a5973e2982eb76a08dc7d3ca5ec9e72e64c9b5efd751001a8999b420b1ad0
DIST surreal-gentoo.tar.gz 13410 BLAKE2B e7d902278004785c68a2e5aa02aa326cee1ef04fe964fce283afde00cb668b06d5d8461207ef9571aa402b960ec16bdff6bf11cf38ca9a76335ced173592ffce SHA512 dd43cb78e5e33345767edad22d0470765ac9eeae02bbad0acd8098bc096c15a166bf651493d12a5953bc043c9be92e9b160607eafb4723a6bcfc5d1d6fae235e
EBUILD openbox-3.6.1-r5.ebuild 2903 BLAKE2B 75ad51841c606570d9caa705aec928ed012456447f424249dfa71041925160846099f7c625a7cedbd132a1e86a99e8460a73ed36ac3b1a144021abc8f1208c1c SHA512 7f2ead2acc3777644f74786a4f95c7e1b35105485e6b0e3ff996730d916c9924c019e7ea8fabd4918d54fb03134841d64a5e814bd1e8b7937ef81c0506562e31
-EBUILD openbox-9999.ebuild 2833 BLAKE2B a4b70f0a3a03559f9a161aabb144b809dc920082023b7ae8a9c42d3d8a676060abb5fc66626e35a2a53aa8611af07d2a39624f1320a1c4effea51037ff77571f SHA512 ad16d4ef7f89fa44a4e242ad2d7bb3e1f219172eb36e90177951e80b2f21c6761ea4765a7ab65d392a22ab4b16621ed3adfd45f5c8bfb2a233f29b11581315d2
+EBUILD openbox-3.6.1-r7.ebuild 2857 BLAKE2B c81b6d32139612d9f2c625b6bd2bde1ddcd179dffffd96f4f30f1519895ca99747d4318196f9897562f7390a6abf96939f9edfe0f4d1531fffa3124331409156 SHA512 3861e45a3ebfc971dffa4ee57e3e2a4266ec6d2837612ea206b92a903e35e38ee1270d0e965ded3ecda4b5e5b97651ab27f16ffe229c63c3808a4a34efb2bf9c
+EBUILD openbox-9999.ebuild 2857 BLAKE2B c81b6d32139612d9f2c625b6bd2bde1ddcd179dffffd96f4f30f1519895ca99747d4318196f9897562f7390a6abf96939f9edfe0f4d1531fffa3124331409156 SHA512 3861e45a3ebfc971dffa4ee57e3e2a4266ec6d2837612ea206b92a903e35e38ee1270d0e965ded3ecda4b5e5b97651ab27f16ffe229c63c3808a4a34efb2bf9c
MISC metadata.xml 705 BLAKE2B 0df8e542b8837fb94e5f6fd289b0d5172c1d4d01bc88c550b6afd5307619a0dfdf5de2c2ba8838d63f8a8c29a378e6545a8932c77d6f0bef7cc898a4fd400206 SHA512 acf171ad8ccc7d07b533e4f5aef895b485050fa8fa39d8a6db798a15d9c5924d4f825573b77ddd8b755b8c0b34e8c3ab49cd0f56592854ae36462c3de448f4dc
diff --git a/x11-wm/openbox/openbox-3.6.1-r7.ebuild b/x11-wm/openbox/openbox-3.6.1-r7.ebuild
new file mode 100644
index 000000000000..3a35c296e216
--- /dev/null
+++ b/x11-wm/openbox/openbox-3.6.1-r7.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11})
+inherit autotools python-single-r1
+
+DESCRIPTION="Standards compliant, fast, light-weight, extensible window manager"
+HOMEPAGE="http://openbox.org/wiki/Main_Page"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Mikachu/openbox.git"
+else
+ SRC_URI="http://openbox.org/dist/openbox/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x86-linux"
+fi
+
+SRC_URI+=" branding? ( https://dev.gentoo.org/~hwoarang/distfiles/surreal-gentoo.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="3"
+IUSE="branding debug imlib nls session startup-notification svg xdg"
+REQUIRED_USE="xdg? ( ${PYTHON_REQUIRED_USE} )"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+RDEPEND="
+ dev-libs/glib:2
+ >=dev-libs/libxml2-2.0
+ >=media-libs/fontconfig-2
+ x11-libs/cairo
+ x11-libs/libXau
+ x11-libs/libXcursor
+ x11-libs/libXext
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXt
+ >=x11-libs/pango-1.8[X]
+ imlib? ( media-libs/imlib2 )
+ startup-notification? ( >=x11-libs/startup-notification-0.8 )
+ svg? ( gnome-base/librsvg:2 )
+ xdg? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')
+ )
+"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.5.2-gnome-session.patch"
+ # see https://github.com/danakj/openbox/pull/35
+ "${FILESDIR}/${PN}-3.6.1-py3-xdg.patch"
+ # https://bugs.gentoo.org/827227
+ "${FILESDIR}/${PN}-3.6.1-getgrent-to-getgroups.patch"
+ # https://bugs.gentoo.org/901777
+ "${FILESDIR}/${PN}-3.6.1-glib-2.76.patch"
+)
+
+pkg_setup() {
+ use xdg && python-single-r1_pkg_setup
+}
+
+src_unpack() {
+ if [[ ${PV} == *9999* ]]; then
+ git-r3_src_unpack
+ fi
+
+ default
+}
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s:-O0 -ggdb ::" \
+ -e 's/-fno-strict-aliasing//' \
+ m4/openbox.m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-static
+ --with-x
+ $(use_enable debug)
+ $(use_enable imlib imlib2)
+ $(use_enable nls)
+ $(use_enable session session-management)
+ $(use_enable startup-notification)
+ $(use_enable svg librsvg)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ ${PN}
+ EOF
+
+ emake DESTDIR="${D}" install
+ if use branding; then
+ insinto /usr/share/themes
+ doins -r "${WORKDIR}"/Surreal_Gentoo
+ # make it the default theme
+ sed -i \
+ -e "/<theme>/{n; s@<name>.*</name>@<name>Surreal_Gentoo</name>@}" \
+ "${D}"/etc/xdg/openbox/rc.xml \
+ || die "failed to set Surreal Gentoo as the default theme"
+ fi
+ find "${ED}" -name '*.la' -delete || die
+ if use xdg ; then
+ python_fix_shebang "${ED}"/usr/libexec/openbox-xdg-autostart
+ else
+ rm "${ED}"/usr/libexec/openbox-xdg-autostart || die
+ fi
+}
diff --git a/x11-wm/openbox/openbox-9999.ebuild b/x11-wm/openbox/openbox-9999.ebuild
index d753cdef761b..3a35c296e216 100644
--- a/x11-wm/openbox/openbox-9999.ebuild
+++ b/x11-wm/openbox/openbox-9999.ebuild
@@ -61,6 +61,8 @@ PATCHES=(
"${FILESDIR}/${PN}-3.6.1-py3-xdg.patch"
# https://bugs.gentoo.org/827227
"${FILESDIR}/${PN}-3.6.1-getgrent-to-getgroups.patch"
+ # https://bugs.gentoo.org/901777
+ "${FILESDIR}/${PN}-3.6.1-glib-2.76.patch"
)
pkg_setup() {
@@ -99,9 +101,12 @@ src_configure() {
}
src_install() {
- dodir /etc/X11/Sessions
- echo "/usr/bin/openbox-session" > "${ED}/etc/X11/Sessions/${PN}"
- fperms a+x /etc/X11/Sessions/${PN}
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ ${PN}
+ EOF
+
emake DESTDIR="${D}" install
if use branding; then
insinto /usr/share/themes