summaryrefslogtreecommitdiff
path: root/x11-wm/notion/notion-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/notion/notion-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/notion/notion-9999.ebuild')
-rw-r--r--x11-wm/notion/notion-9999.ebuild86
1 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/notion/notion-9999.ebuild b/x11-wm/notion/notion-9999.ebuild
new file mode 100644
index 000000000000..7e3e396b1255
--- /dev/null
+++ b/x11-wm/notion/notion-9999.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils git-r3 multilib toolchain-funcs readme.gentoo
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="http://notion.sourceforge.net"
+EGIT_REPO_URI="https://github.com/raboof/${PN}.git"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="nls xinerama +xrandr"
+
+RDEPEND=">=dev-lang/lua-5.1:0=
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+# mod_xrandr references mod_xinerama
+REQUIRED_USE="xrandr? ( xinerama )"
+
+# needs luaposix,slingshot,... not in tree
+RESTRICT=test
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-3_p2015061300-pkg-config.patch"
+
+ sed -e "/^CFLAGS/{s: =: +=: ; s:-Os:: ; s:-g::}" \
+ -e "/^LDFLAGS/{s: =: +=: ; s:-Wl,--as-needed::}" \
+ -i system-autodetect.mk || die
+ echo > build/lua-detect.mk
+}
+
+src_configure() {
+ { echo "CFLAGS += -D_DEFAULT_SOURCE"
+ echo "PREFIX=${ROOT}usr"
+ echo "DOCDIR=\$(PREFIX)/share/doc/${PF}"
+ echo "ETCDIR=${ROOT}etc/${PN}"
+ echo "LIBDIR=\$(PREFIX)/$(get_libdir)"
+ echo "VARDIR=${ROOT}var/cache/${PN}"
+ echo "X11_PREFIX=${ROOT}usr"
+ echo "STRIPPROG=true"
+ echo "CC=$(tc-getCC)"
+ echo "AR=$(tc-getAR)"
+ echo "RANLIB=$(tc-getRANLIB)"
+ echo "LUA_MANUAL=1"
+ echo "LUA=\$(BINDIR)/lua"
+ echo "LUAC=\$(BINDIR)/luac"
+ echo "LUA_LIBS=\$(shell pkg-config --libs lua)"
+ echo "LUA_INCLUDES=\$(shell pkg-config --cflags)"
+ use nls || echo "DEFINES+=-DCF_NO_LOCALE -DCF_NO_GETTEXT"
+ } > system-local.mk
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ sed -e '/mod_xrandr/d' \
+ -i etc/cfg_defaults.lua || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+
+ readme.gentoo_src_install
+}
+
+DOC_CONTENTS="If you want notion to have an ability to view a file based on its
+guessed MIME type you should emerge app-misc/run-mailcap."