summaryrefslogtreecommitdiff
path: root/x11-wm/metacity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-wm/metacity
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-wm/metacity')
-rw-r--r--x11-wm/metacity/Manifest2
-rw-r--r--x11-wm/metacity/metacity-3.36.1.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-wm/metacity/Manifest b/x11-wm/metacity/Manifest
index 6ab368343586..3bc92a7c5272 100644
--- a/x11-wm/metacity/Manifest
+++ b/x11-wm/metacity/Manifest
@@ -1,3 +1,5 @@
DIST metacity-3.34.1.tar.xz 2055708 BLAKE2B c1bac27f83d26718fa3d02f777a627324efc3e3eaffbf385a84dd97960adc30e84090f511500fe96a4fbbb373da80a38eaba4c5e14910fbcf8783857c0767ef2 SHA512 e9234ad0aee9fe27cf1c2030e31d8f2c292ae2ee2e9b8546ed86e396152faa9dc4cc67fa8321a0c3d3bf577a83bc143111c6ac225f423db243347a6a760695ee
+DIST metacity-3.36.1.tar.xz 2063452 BLAKE2B 2dd7b1c63e0b5f87ce4518d7d42d472223717012a46dd826dfda3c88f7e647809e6bf2449a28bd38573342fd5fec94e2233db958658ea4320b22c5451390e451 SHA512 98e73036cca238b713a112194b2cd7a866bcf7d08ef29fb590054b69a1bd807699317a51f9b851f9c474ae2557e27dc9fc4a52d7c436d93ad4a02babef68feeb
EBUILD metacity-3.34.1.ebuild 1233 BLAKE2B 6849286bfcc9997d335d7e842a6b03a6150707adae71c0f224b7d4dbe2fe41d3fbf0c89d18780b4f3b36dee20c01026171caa98cae840751b30ef8fe18550a96 SHA512 3519262f4f14a86750a3f833adcb8ef88282ef797c2c2a8c47531ff507d6f81713f336e8a04eb2573b9e485db427de10d7a4469a2b4a832994b48cbcc8c4c621
+EBUILD metacity-3.36.1.ebuild 1230 BLAKE2B 5ed0a66a03c26b6dec890a10cefe295d703df73b2af5fa996d192d3f91d30f454a359886a71b329cc95f980541231ede4eb724d63dd3f828bc07f4316c9cf852 SHA512 55217e43229292e884d88d4abc6f88b7626ef41904127e0b39f77da84d44d73970f53bac28d803eff48ede7b5fa07cd8c2a06476b9aab021037e5932b4fedcf8
MISC metadata.xml 477 BLAKE2B 592b2957c7bff2b55505a056a2eef8d8cec25eecb400b5046bfbbd84eadfc6baa1f1475fd772a568538360c6867f0b5c0934d85bc5c6fd6ad362d80bad31ea33 SHA512 e475ae41ee3fa97f037acca5634bcb8ded17e783183459aeb83b3566df36fe7d09832991e9252f59e900982bcd0c80e8987bccc2c3e042080405d5448af9423a
diff --git a/x11-wm/metacity/metacity-3.36.1.ebuild b/x11-wm/metacity/metacity-3.36.1.ebuild
new file mode 100644
index 000000000000..bc33e8f6558b
--- /dev/null
+++ b/x11-wm/metacity/metacity-3.36.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="GNOME Flashback window manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/metacity/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+libcanberra vulkan xinerama"
+KEYWORDS="~amd64"
+
+# TODO: libgtop could be optional, but no knob
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=x11-libs/gtk+-3.22.0:3[X]
+ >=x11-libs/pango-1.2.0
+ >=x11-libs/libXcomposite-0.3
+ >=gnome-base/gsettings-desktop-schemas-3.3.0
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ libcanberra? ( media-libs/libcanberra[gtk3] )
+ >=x11-libs/startup-notification-0.7
+ x11-libs/libXcursor
+ gnome-base/libgtop:2=
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXrandr
+ x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ gnome-extra/zenity
+ vulkan? ( media-libs/vulkan-loader )
+"
+DEPEND="${RDEPEND}
+ vulkan? ( dev-util/vulkan-headers )
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.4
+ x11-base/xorg-proto
+ virtual/pkgconfig
+" # autoconf-archive for eautoreconf
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable libcanberra canberra) \
+ $(use_enable xinerama) \
+ $(use_enable vulkan)
+}