summaryrefslogtreecommitdiff
path: root/x11-wm/icewm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/icewm/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/icewm/files')
-rw-r--r--x11-wm/icewm/files/IceWM.desktop8
-rw-r--r--x11-wm/icewm/files/icewm2
-rw-r--r--x11-wm/icewm/files/icewm-1.3.10-menu.patch22
-rw-r--r--x11-wm/icewm/files/icewm-1.3.7-dso.patch10
-rw-r--r--x11-wm/icewm/files/icewm-1.3.7-gcc44.patch13
-rw-r--r--x11-wm/icewm/files/icewm-1.3.7-menuiconsize.patch73
-rw-r--r--x11-wm/icewm/files/icewm-1.3.7-thermal.patch41
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch113
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-deprecated.patch12
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-menu.patch23
-rw-r--r--x11-wm/icewm/files/icewm-1.3.8-uclibc.patch64
-rw-r--r--x11-wm/icewm/files/icewm-defaults.patch13
-rw-r--r--x11-wm/icewm/files/icewm-fribidi.patch83
-rw-r--r--x11-wm/icewm/files/icewm-keys.patch43
-rw-r--r--x11-wm/icewm/files/icewm-startup4
-rw-r--r--x11-wm/icewm/files/icewm-toolbar.patch12
-rw-r--r--x11-wm/icewm/files/icewm-xdg-menu128
17 files changed, 664 insertions, 0 deletions
diff --git a/x11-wm/icewm/files/IceWM.desktop b/x11-wm/icewm/files/IceWM.desktop
new file mode 100644
index 000000000000..087384ee1308
--- /dev/null
+++ b/x11-wm/icewm/files/IceWM.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=IceWM
+Comment=This session logs you into IceWM
+Exec=icewm-session
+TryExec=icewm-session
+# no icon yet, only the top three are currently used
+Icon=
+Type=Application
diff --git a/x11-wm/icewm/files/icewm b/x11-wm/icewm/files/icewm
new file mode 100644
index 000000000000..90905960d1a2
--- /dev/null
+++ b/x11-wm/icewm/files/icewm
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/icewm-session
diff --git a/x11-wm/icewm/files/icewm-1.3.10-menu.patch b/x11-wm/icewm/files/icewm-1.3.10-menu.patch
new file mode 100644
index 000000000000..721a15d25ee3
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.10-menu.patch
@@ -0,0 +1,22 @@
+--- icewm-1.3.10/lib/menu.in
++++ icewm-1.3.10/lib/menu.in
+@@ -4,14 +4,9 @@
+ # since modifications to this file will be discarded when you
+ # (re)install icewm.
+ #
+-prog xterm xterm xterm
+-prog rxvt xterm rxvt -bg black -cr green -fg white -C -fn 9x15 -sl 500
+-prog fte fte fte
+-prog NEdit nedit nedit
+-prog Mozilla mozilla mozilla
+-prog XChat xchat xchat
+-prog Gimp gimp gimp
++prog xterm /usr/share/icons/gnome/16x16/apps/terminal.png xterm
++"Web browser" /usr/share/icons/gnome/16x16/apps/web-browser.png xdg-open about:blank
+ separator
+-menuprog "Desktop Apps" folder icewm-menu-fdo
+-menufile Programs folder programs
+-menufile Tool_bar folder toolbar
++prog "Rebuild program menu" /usr/share/icons/gnome/16x16/actions/edit-find-replace.png /usr/share/icewm/startup
++separator
++menufile Programs folder programs.autogen
diff --git a/x11-wm/icewm/files/icewm-1.3.7-dso.patch b/x11-wm/icewm/files/icewm-1.3.7-dso.patch
new file mode 100644
index 000000000000..55100d5f62a6
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.7-dso.patch
@@ -0,0 +1,10 @@
+--- configure.in.old 2011-11-23 15:44:52.121654867 +0200
++++ configure.in 2011-11-23 15:47:09.514411391 +0200
+@@ -494,6 +494,7 @@
+ AC_DEFINE(CONFIG_COREFONTS, 1, [Define to enable X11 core conts.])
+ features="${features} corefonts"
+ fi
++ CORE_LIBS="${CORE_LIBS} -lfontconfig"
+
+ dnl ============================================================= GUI Events ===
+ dnl
diff --git a/x11-wm/icewm/files/icewm-1.3.7-gcc44.patch b/x11-wm/icewm/files/icewm-1.3.7-gcc44.patch
new file mode 100644
index 000000000000..d500f64004bc
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.7-gcc44.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/show_bug.cgi?id=376451
+
+--- a/src/wmapp.cc
++++ b/src/wmapp.cc
+@@ -337,7 +337,7 @@
+ char ** fontPath(XGetFontPath(xapp->display(), &ndirs));
+
+ char ** newFontPath = new char *[ndirs + 1];
+- newFontPath[ndirs] = fontsdir;
++ newFontPath[ndirs] = (char *)fontsdir;
+
+ if (fontPath)
+ memcpy(newFontPath, fontPath, ndirs * sizeof (char *));
diff --git a/x11-wm/icewm/files/icewm-1.3.7-menuiconsize.patch b/x11-wm/icewm/files/icewm-1.3.7-menuiconsize.patch
new file mode 100644
index 000000000000..d051d5bc5f19
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.7-menuiconsize.patch
@@ -0,0 +1,73 @@
+diff -Naur icewm-1.3.7.bak/src/yicon.cc icewm-1.3.7/src/yicon.cc
+--- icewm-1.3.7.bak/src/yicon.cc 2010-10-31 15:09:36.000000000 +0100
++++ icewm-1.3.7/src/yicon.cc 2011-11-07 19:41:52.841910531 +0100
+@@ -270,6 +270,10 @@
+ iconCache.getItem(0)->removeFromCache();
+ }
+
++int YIcon::menuSize() {
++ return menuIconSize;
++}
++
+ int YIcon::smallSize() {
+ return smallIconSize;
+ }
+diff -Naur icewm-1.3.7.bak/src/yicon.h icewm-1.3.7/src/yicon.h
+--- icewm-1.3.7.bak/src/yicon.h 2010-10-31 15:09:36.000000000 +0100
++++ icewm-1.3.7/src/yicon.h 2011-11-07 19:41:28.555296033 +0100
+@@ -25,6 +25,7 @@
+ bool isCached() { return fCached; }
+ void setCached(bool cached) { fCached = cached; }
+
++ static int menuSize();
+ static int smallSize();
+ static int largeSize();
+ static int hugeSize();
+diff -Naur icewm-1.3.7.bak/src/ymenu.cc icewm-1.3.7/src/ymenu.cc
+--- icewm-1.3.7.bak/src/ymenu.cc 2010-10-31 15:09:36.000000000 +0100
++++ icewm-1.3.7/src/ymenu.cc 2011-11-07 19:42:40.498474049 +0100
+@@ -153,8 +153,8 @@
+
+ #ifndef LITE
+ if (getItem(selItem)->getIcon() != null &&
+- YIcon::smallSize() > h)
+- h = YIcon::smallSize();
++ YIcon::menuSize() > h)
++ h = YIcon::menuSize();
+ #endif
+
+ if (x <= int(width() - h - 4))
+@@ -1023,8 +1023,8 @@
+ mitem->getIcon()->draw(g,
+ l + 1 + delta, t + delta + top + pad +
+ (eh - top - pad * 2 - bottom -
+- YIcon::smallSize()) / 2,
+- YIcon::smallSize());
++ YIcon::menuSize()) / 2,
++ YIcon::menuSize());
+ #endif
+ }
+
+diff -Naur icewm-1.3.7.bak/src/ymenuitem.cc icewm-1.3.7/src/ymenuitem.cc
+--- icewm-1.3.7.bak/src/ymenuitem.cc 2010-10-31 15:09:36.000000000 +0100
++++ icewm-1.3.7/src/ymenuitem.cc 2011-11-07 19:50:04.458316916 +0100
+@@ -86,8 +86,8 @@
+ int ih = fontHeight;
+
+ #ifndef LITE
+- if (YIcon::smallSize() > ih)
+- ih = YIcon::smallSize();
++ if (YIcon::menuSize() > ih)
++ ih = YIcon::menuSize();
+ #endif
+
+ if (wmLook == lookWarp4 || wmLook == lookWin95) {
+@@ -123,7 +123,7 @@
+ return 0;
+ #else
+ ref<YIcon> icon = getIcon();
+- return icon != null ? YIcon::smallSize(): 0;
++ return icon != null ? YIcon::menuSize(): 0;
+ #endif
+ }
+
diff --git a/x11-wm/icewm/files/icewm-1.3.7-thermal.patch b/x11-wm/icewm/files/icewm-1.3.7-thermal.patch
new file mode 100644
index 000000000000..f6b2cf71f0f5
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.7-thermal.patch
@@ -0,0 +1,41 @@
+diff -uprN a/src/acpustatus.cc b/src/acpustatus.cc
+--- a/src/acpustatus.cc 2010-10-31 15:09:36.000000000 +0100
++++ b/src/acpustatus.cc 2013-01-17 21:12:19.085715083 +0100
+@@ -315,6 +315,37 @@ int CPUStatus::getAcpiTemp(char *tempbuf
+ }
+ closedir(dir);
+ }
++ else if ((dir = opendir("/sys/class/thermal")) != NULL) {
++ struct dirent *de;
++
++ while ((de = readdir(dir)) != NULL) {
++
++ int fd, seglen;
++
++ if (strcmp(de->d_name, ".") == 0 || strcmp(de->d_name, "..") == 0)
++ continue;
++
++ sprintf(namebuf, "/sys/class/thermal/%s/temp", de->d_name);
++ fd = open(namebuf, O_RDONLY);
++ if (fd != -1) {
++ int len = read(fd, buf, sizeof(buf) - 1);
++ buf[len - 4] = '\0';
++ seglen = strlen(buf) + 4;
++ if (retbuflen + seglen >= buflen) {
++ retbuflen = -retbuflen;
++ close(fd);
++ closedir(dir);
++ break;
++ }
++ retbuflen += seglen;
++ strcat(tempbuf, " ");
++ strncat(tempbuf, buf, seglen);
++ strcat(tempbuf, " C");
++ close(fd);
++ }
++ }
++ closedir(dir);
++ }
+ return retbuflen;
+ }
+
diff --git a/x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch b/x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch
new file mode 100644
index 000000000000..cec27a79ad0a
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-build-fixes.patch
@@ -0,0 +1,113 @@
+--- icewm-1.3.8/Makefile.in
++++ icewm-1.3.8/Makefile.in
+@@ -35,7 +35,7 @@
+
+ ################################################################################
+
+-BINFILES = @BINFILES@ icewm-set-gnomewm
++BINFILES = @BINFILES@ "$(srcdir)/icewm-set-gnomewm"
+ LIBFILES = lib/preferences lib/winoptions lib/keys \
+ lib/menu lib/toolbar # lib/programs
+ DOCFILES = README BUGS CHANGES COPYING AUTHORS INSTALL VERSION icewm.lsm
+@@ -83,21 +83,23 @@
+ @echo ------------------------------------------
+ @echo "Installing binaries in $(DESTDIR)$(BINDIR)"
+ @$(INSTALLDIR) "$(DESTDIR)$(BINDIR)"
++#generated files, relative to the build directory
+ @for bin in $(BINFILES); do \
+ $(INSTALLBIN) "$${bin}" "$(DESTDIR)$(BINDIR)"; \
+ done
+
+ @echo "Installing presets and icons in $(DESTDIR)$(LIBDIR)"
+ @$(INSTALLDIR) "$(DESTDIR)$(LIBDIR)"
++# data files from the source directory
+ #-@$(INSTALLDIR) "$(DESTDIR)$(CFGDIR)"
+ @for lib in $(LIBFILES); do \
+- $(INSTALLLIB) "$${lib}" "$(DESTDIR)$(LIBDIR)"; \
++ $(INSTALLLIB) "$(top_srcdir)/$${lib}" "$(DESTDIR)$(LIBDIR)"; \
+ done
+
+ @for xpmdir in $(XPMDIRS); do \
+- if test -d "lib/$${xpmdir}"; then \
++ if test -d "$(top_srcdir)/lib/$${xpmdir}"; then \
+ $(INSTALLDIR) "$(DESTDIR)$(LIBDIR)/$${xpmdir}"; \
+- for pixmap in "lib/$${xpmdir}/"*.xpm; do \
++ for pixmap in "$(top_srcdir)/lib/$${xpmdir}/"*.xpm; do \
+ $(INSTALLLIB) "$${pixmap}" "$(DESTDIR)$(LIBDIR)/$${xpmdir}"; \
+ done; \
+ fi; \
+--- icewm-1.3.8/po/Makefile.in
++++ icewm-1.3.8/po/Makefile.in
+@@ -20,6 +20,7 @@
+ XGETTEXT = @XGETTEXT@
+ MSGMERGE = @MSGMERGE@
+ MSGFMT = @MSGFMT@
++VPATH = .:po:@srcdir@
+
+ .SUFFIXES:
+ .SUFFIXES: .po .mo
+--- icewm-1.3.8/src/Makefile.in
++++ icewm-1.3.8/src/Makefile.in
+@@ -11,7 +11,7 @@
+
+ CXX = @CXX@
+ HOSTCXX = @HOSTCXX@
+-LD = @CXX_LINK@
++LD = gcc
+ HOSTLD = @HOSTCXX_LINK@
+ EXEEXT = @EXEEXT@
+
+@@ -32,12 +32,12 @@
+ -DICEWMBGEXE='"icewmbg$(EXEEXT)"' \
+ -DICESMEXE='"icewm-session$(EXEEXT)"' \
+ -DICEHELPEXE='"icehelp$(EXEEXT)"' \
+- -DICEHELPIDX='"$(DOCDIR)/icewm-$(VERSION)/icewm.html"'
++ -DICEHELPIDX='"$(DOCDIR)/icewm-common/icewm.html"'
+
+ CXXFLAGS = @CXXFLAGS@ $(DEBUG) $(DEFS) `pkg-config gdk-pixbuf-xlib-2.0 --cflags` \
+ @CORE_CFLAGS@ @IMAGE_CFLAGS@ @AUDIO_CFLAGS@ `pkg-config fontconfig --cflags`
+ LFLAGS = @LDFLAGS@
+-LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs`
++LIBS = @LIBS@ `pkg-config gdk-pixbuf-xlib-2.0 --libs` -lfontconfig -lm -lsupc++
+
+ CORE_LIBS = @CORE_LIBS@ `pkg-config fontconfig --libs`
+ IMAGE_LIBS = @IMAGE_LIBS@
+@@ -188,6 +188,8 @@
+ TESTCASES = @TESTCASES@
+ OBJECTS = @BASEOBJS@ @TESTOBJS@
+ BINARIES = @BASEBINS@ @TESTBINS@
++BASEOBJS = @BASEOBJS@
++VPATH = .:@srcdir@
+
+ ################################################################################
+
+@@ -205,7 +207,8 @@
+ @echo " CXX " $@
+ @$(CXX) $(CXXFLAGS) $(GCCDEP) -c $<
+
+-$(BINARIES):
++$(BINARIES): $(BASEOBJS)
++# @$(MAKE) --no-print-directory build-dep DEPLIST="$($(@:$(EXEEXT)=)_OBJS)"
+ @echo " LD " $@
+ @$(LD) -o $@ $($(@:$(EXEEXT)=)_OBJS) $(LFLAGS) $($(@:$(EXEEXT)=)_LFLAGS) $(LIBS) $($(@:$(EXEEXT)=)_LIBS)
+
+@@ -217,6 +220,8 @@
+ @echo " HOSTLD " $@
+ @$(HOSTLD) -o $@ $(genpref_OBJS)
+
++build-dep: $(DEPLIST)
++
+ ################################################################################
+
+ gnome2.o: gnome2.cc
+--- icewm-1.3.8/src/WinMgr.h
++++ icewm-1.3.8/src/WinMgr.h
+@@ -128,7 +128,7 @@
+ * this where WIN_WORKSPACE_COUNT comes into play.
+ */
+
+-#define WinWorkspaceInvalid (-1L)
++#define WinWorkspaceInvalid ((unsigned long)-1)
+
+ /* workspaces */
+ #define XA_WIN_WORKSPACES "_WIN_WORKSPACES"
diff --git a/x11-wm/icewm/files/icewm-1.3.8-deprecated.patch b/x11-wm/icewm/files/icewm-1.3.8-deprecated.patch
new file mode 100644
index 000000000000..b956180627bc
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-deprecated.patch
@@ -0,0 +1,12 @@
+--- icewm-1.3.8/src/base.h
++++ icewm-1.3.8/src/base.h
+@@ -2,7 +2,9 @@
+ #define __BASE_H
+
+ #if ( __GNUC__ == 3 && __GNUC_MINOR__ > 0 ) || __GNUC__ > 3
++#if ( __GNUC__ == 4 && __GNUC_MINOR__ > 7 ) || __GNUC__ > 3
+ #define _icewm_deprecated __attribute__((deprecated))
++#endif
+ #else
+ #define _icewm_deprecated
+ #endif
diff --git a/x11-wm/icewm/files/icewm-1.3.8-menu.patch b/x11-wm/icewm/files/icewm-1.3.8-menu.patch
new file mode 100644
index 000000000000..e4bab5c5ffc3
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-menu.patch
@@ -0,0 +1,23 @@
+--- icewm-1.3.8/lib/menu.in
++++ icewm-1.3.8/lib/menu.in
+@@ -4,15 +4,9 @@
+ # since modifications to this file will be discarded when you
+ # (re)install icewm.
+ #
+-prog xterm xterm xterm
+-prog rxvt xterm rxvt -bg black -cr green -fg white -C -fn 9x15 -sl 500
+-prog fte fte fte
+-prog NEdit nedit nedit
+-prog Mozilla mozilla mozilla
+-prog XChat xchat xchat
+-prog Gimp gimp gimp
++prog xterm /usr/share/icons/gnome/16x16/apps/terminal.png xterm
++prog "Web browser" /usr/share/icons/gnome/16x16/apps/web-browser.png xdg-open about:blank
+ separator
+-menuprog Gnome folder icewm-menu-gnome2 --list @CONFIG_GNOME2_MENU_DIR@
+-menuprog KDE folder icewm-menu-gnome@GNOME_VER@ --list @CONFIG_KDE_MENU_DIR@
+-menufile Programs folder programs
+-menufile Tool_bar folder toolbar
++prog "Rebuild program menu" /usr/share/icons/gnome/16x16/actions/edit-find-replace.png /usr/share/icewm/startup
++separator
++menufile Programs folder programs.autogen
diff --git a/x11-wm/icewm/files/icewm-1.3.8-uclibc.patch b/x11-wm/icewm/files/icewm-1.3.8-uclibc.patch
new file mode 100644
index 000000000000..e790842faed8
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.3.8-uclibc.patch
@@ -0,0 +1,64 @@
+diff -Naur icewm-1.3.7.orig/configure.in icewm-1.3.7/configure.in
+--- icewm-1.3.7.orig/configure.in 2010-10-31 10:09:37.000000000 -0400
++++ icewm-1.3.7/configure.in 2013-10-19 06:20:22.947520430 -0400
+@@ -113,6 +113,7 @@
+ AC_CHECK_HEADERS(libgen.h) dnl -- basename() for FreeBSD
+ AC_CHECK_HEADERS(machine/apmvar.h)
+ AC_CHECK_HEADERS(machine/apm_bios.h)
++AC_CHECK_HEADERS(execinfo.h)
+
+ AC_CHECK_HEADERS(kstat.h,
+ [ CORE_LIBS="${CORE_LIBS} -lkstat"
+diff -Naur icewm-1.3.7.orig/src/acpustatus.cc icewm-1.3.7/src/acpustatus.cc
+--- icewm-1.3.7.orig/src/acpustatus.cc 2010-10-31 10:09:36.000000000 -0400
++++ icewm-1.3.7/src/acpustatus.cc 2013-10-19 06:20:18.355519888 -0400
+@@ -25,17 +25,12 @@
+ #include "sysdep.h"
+ #include "default.h"
+
+-#if defined(linux)
+-//#include <linux/kernel.h>
+-#include <sys/sysinfo.h>
+-#endif
+ #if defined(sun) && defined(SVR4)
+ #include <sys/loadavg.h>
+ #endif
+ #ifdef HAVE_KSTAT_H
+ #include <sys/resource.h>
+ #include <kstat.h>
+-#include <sys/sysinfo.h>
+ #endif
+
+ #ifdef HAVE_SYS_PARAM_H
+@@ -56,6 +51,10 @@
+ #include <dirent.h>
+ #include "intl.h"
+
++#if defined(linux) || defined(HAVE_KSTAT_H)
++#include <sys/sysinfo.h>
++#endif
++
+ #if (defined(linux) || defined(HAVE_KSTAT_H)) || defined(HAVE_SYSCTL_CP_TIME)
+
+ extern ref<YPixmap> taskbackPixmap;
+diff -Naur icewm-1.3.7.orig/src/misc.cc icewm-1.3.7/src/misc.cc
+--- icewm-1.3.7.orig/src/misc.cc 2010-10-31 10:09:36.000000000 -0400
++++ icewm-1.3.7/src/misc.cc 2013-10-19 06:20:22.947520430 -0400
+@@ -15,7 +15,7 @@
+ #include <libgen.h>
+ #endif
+
+-#ifdef linux
++#if defined(linux) && defined(HAVE_EXECINFO_H)
+ #include <execinfo.h>
+ #endif
+
+@@ -503,7 +503,7 @@
+ }
+
+ void show_backtrace() {
+-#ifdef linux
++#if defined(linux) && defined(HAVE_EXECINFO_H)
+ const char head[] = "\nbacktrace:\n";
+ const char tail[] = "end\n";
+ void *array[20];
diff --git a/x11-wm/icewm/files/icewm-defaults.patch b/x11-wm/icewm/files/icewm-defaults.patch
new file mode 100644
index 000000000000..72e5410db4fe
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-defaults.patch
@@ -0,0 +1,13 @@
+--- src/default.h.old 2011-11-23 18:04:22.429626938 +0200
++++ src/default.h 2011-11-23 18:04:38.416824083 +0200
+@@ -161,8 +161,8 @@
+ #endif
+
+ XSV(const char *, mailBoxPath, 0)
+-XSV(const char *, mailCommand, "xterm -name pine -title PINE -e pine")
+-XSV(const char *, mailClassHint, "pine.XTerm")
++XSV(const char *, mailCommand, "xterm -name alpine -title ALPINE -e alpine")
++XSV(const char *, mailClassHint, "alpine.XTerm")
+ XSV(const char *, newMailCommand, 0)
+ XSV(const char *, lockCommand, 0)
+ XSV(const char *, clockCommand, "xclock -name icewm -title Clock")
diff --git a/x11-wm/icewm/files/icewm-fribidi.patch b/x11-wm/icewm/files/icewm-fribidi.patch
new file mode 100644
index 000000000000..66691d78a3ff
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-fribidi.patch
@@ -0,0 +1,83 @@
+--- src/yfontxft.cc.old 2009-09-25 00:07:51.000000000 +0300
++++ src/yfontxft.cc 2009-09-25 00:18:09.000000000 +0300
+@@ -6,6 +6,11 @@
+ #include "ypaint.h"
+ #include "yxapp.h"
+ #include "intl.h"
++#include <stdio.h>
++
++#ifdef CONFIG_FRIBIDI
++ #include <fribidi/fribidi.h>
++#endif
+
+ /******************************************************************************/
+
+@@ -68,10 +73,45 @@
+ char_t * str, size_t len)
+ {
+ XftColor *c = *g.color();
++
++#ifdef CONFIG_FRIBIDI
++
++#define STATIS_STRING_SIZE 256
++
++ // Based around upstream (1.3.2) patch with some optimization
++ // on my end. (reduce unnecessary memory allocation)
++ // - Gilboa
++
++ char_t static_str[STATIS_STRING_SIZE];
++ char_t *vis_str = static_str;
++
++ if (len >= STATIS_STRING_SIZE)
++ {
++ vis_str = new char_t[len+1];
++ if (!vis_str)
++ return;
++ }
++
++ FriBidiCharType pbase_dir = FRIBIDI_TYPE_N;
++ fribidi_log2vis(str, len, &pbase_dir, //input
++ vis_str, // output
++ NULL, NULL, NULL // "statistics" that we don't need
++ );
++ str = vis_str;
++#endif
++
+ XftDrawString(g.handleXft(), c, font,
+ x - g.xorigin(),
+ y - g.yorigin(),
+ str, len);
++
++#ifdef CONFIG_FRIBIDI
++
++ if (vis_str != static_str)
++ delete[] str;
++
++#endif
++
+ }
+
+ static void textExtents(XftFont * font, char_t * str, size_t len,
+--- configure.in.old 2009-09-25 00:05:08.000000000 +0300
++++ configure.in 2009-09-25 00:07:14.000000000 +0300
+@@ -307,6 +307,20 @@
+ features="${features} i18n"
+ fi
+
++dnl =================================================== Right to left support ===
++dnl
++AC_ARG_ENABLE(fribidi,
++ [ --disable-fribidi Disable right to left support])
++
++if test "$enable_fribidi" != "no" && test "$enable_i18n" != "no"; then
++ PKG_CHECK_MODULES(FRIBIDI, fribidi)
++
++ AC_DEFINE(CONFIG_FRIBIDI,1, [Define to enable fribidi support])
++
++ CORE_CFLAGS="${CORE_CFLAGS} ${FRIBIDI_CFLAGS}"
++ CORE_LIBS="${CORE_LIBS} ${FRIBIDI_LIBS}"
++fi
++
+ dnl ============================================================ NLS Support ===
+ dnl
+ AC_ARG_ENABLE(nls,
diff --git a/x11-wm/icewm/files/icewm-keys.patch b/x11-wm/icewm/files/icewm-keys.patch
new file mode 100644
index 000000000000..7e136bb93288
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-keys.patch
@@ -0,0 +1,43 @@
+--- icewm-1.2.30/lib/keys.in.old 2007-01-18 13:55:20.000000000 +0200
++++ icewm-1.2.30/lib/keys.in 2007-01-18 16:07:07.000000000 +0200
+@@ -9,28 +9,21 @@
+ # You'll have to omit XK_ prefixs and to replace XF86XK_ prefixes by
+ # XF86. Valid modifiers are Alt, Ctrl, Shift, Meta, Super and Hyper.
+ #
+-key "Alt+Ctrl+t" xterm
+-key "Alt+Ctrl+f" fte
+-key "Alt+Ctrl+e" nedit
+-key "Alt+Ctrl+g" gimp
+-key "Alt+Ctrl+n" netscape -noraise -remote openBrowser
+-key "Alt+Ctrl+b" netscape -noraise -remote openBookmarks
+-key "Alt+Ctrl+m" netscape -noraise -remote openURL(mailto:,new-window)
++key "Alt+Ctrl+t" xterm
++key "Alt+Ctrl+b" xdg-open about:blank
++key "Alt+Ctrl+s" xdg-open http://www.google.com
+
+-key "Alt+Ctrl+KP_Divide" aumix -v -5 # lower volume
+-key "Alt+Ctrl+KP_Multiply" aumix -v +5 # raise volume
++key "Super+KP_Subtract" amixer sset PCM 5%-
++key "Super+KP_Add" amixer sset PCM 5%+
+
+ # "Multimedia key" bindings for XFree86. Gather the keycodes of your
+ # advanced function keys by watching the output of the xev command whilest
+ # pressing those keys and map those symbols by using xmodmap.
+
+-key "XF86Standby" killall -QUIT icewm
+-key "XF86AudioLowerVolume" aumix -v -5
+-key "XF86AudioRaiseVolume" aumix -v +5
+-key "XF86AudioMute" aumix -v 0
+-key "XF86AudioPlay" cdplay play 1
+-key "XF86AudioStop" cdplay stop
+-key "XF86HomePage" netscape -noraise -remote openHomepage
+-key "XF86Mail" netscape -noraise -remote openURL(mailto:,new-window)
+-key "XF86Search" netscape -noraise -remote openURL(http://www.google.com/)
+-key "XF86Eject" eject
++key "XF86Standby" killall -QUIT icewm
++key "XF86AudioLowerVolume" amixer sset PCM 5%-
++key "XF86AudioRaiseVolume" amixer sset PCM 5%+
++key "XF86AudioMute" amixer sset PCM 0%
++key "XF86HomePage" xdg-open about:blank
++key "XF86Search" xdg-open http://www.google.com
++key "XF86Eject" eject
diff --git a/x11-wm/icewm/files/icewm-startup b/x11-wm/icewm/files/icewm-startup
new file mode 100644
index 000000000000..048ab5938486
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-startup
@@ -0,0 +1,4 @@
+#!/bin/sh
+[ ! -d ~/.icewm ] && mkdir ~/.icewm
+XDG_MENU_PREFIX="gnome-" icewm-xdg-menu --entire-menu --with-theme-paths --icon-size 16 --theme gnome > ~/.icewm/programs.autogen
+
diff --git a/x11-wm/icewm/files/icewm-toolbar.patch b/x11-wm/icewm/files/icewm-toolbar.patch
new file mode 100644
index 000000000000..a6f0f15f52d3
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-toolbar.patch
@@ -0,0 +1,12 @@
+--- icewm-1.2.30/lib/toolbar.in.old 2007-01-18 18:51:55.000000000 +0200
++++ icewm-1.3.7/lib/toolbar.in 2012-06-10 09:36:00.000000000 +0200
+@@ -4,6 +4,6 @@
+ # since modifications to this file will be discarded when you
+ # (re)install icewm.
+ #
+-prog XTerm xterm xterm
+-prog FTE fte fte
+-prog Netscape netscape netscape
++prog xterm /usr/share/icons/gnome/16x16/apps/terminal.png xterm
++prog "Web browser" /usr/share/icons/gnome/16x16/apps/web-browser.png xdg-open about:blank
++
diff --git a/x11-wm/icewm/files/icewm-xdg-menu b/x11-wm/icewm/files/icewm-xdg-menu
new file mode 100644
index 000000000000..529f9e2ab3b4
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-xdg-menu
@@ -0,0 +1,128 @@
+#!/usr/bin/python2
+"""
+This script generates FreeDesktop application menu for IceWM window manager.
+
+Written by Konstantin Korikov <lostclus@ua.fm>, put in the public domain
+
+Requires pyxdg http://cvs.freedesktop.org/cgi-bin/viewcvs.cgi/pyxdg/
+
+USAGE EXAMPLE
+
+Add to $HOME/.icewm/menu this line:
+
+ menuprog Applications - icewm-xdg-menu
+
+and restart IceWM.
+"""
+
+import sys
+import locale
+import getopt
+import re
+import xdg.Menu
+import xdg.DesktopEntry
+import xdg.IconTheme
+import xdg.Config
+
+version = "0.3"
+
+def print_usage(exit_code = 1):
+ print """Usage: %s [options]
+Options:
+ --locale=locale set output languege and encoding
+ --root-folder folder folder to generate (for example: /Games)
+ --terminal command set terminal emulator command (default: xterm -e %%s)
+ --default-folder-icon icon icon for folders that not provide Icon option
+ --default-entry-icon icon icon for entries that not provide Icon option
+ --with-theme-paths convert icon base names to icon absolute paths
+ using icon theme
+ --entire-menu print entire menu
+ --icon-size set default icon size
+ --theme theme set icon theme
+ --help print this help and exit
+ --version print version and exit
+""" % sys.argv[0]
+ sys.exit(exit_code)
+
+def print_version():
+ print "%s version %s" % (
+ os.path.basename(sys.argv[0]), version)
+ sys.exit(0)
+
+root_folder = ""
+terminal = "xterm -e %s"
+default_folder_icon = "folder"
+default_entry_icon = "-"
+entire_menu = False
+with_theme_paths = False
+icon_size = 16
+
+exec_clean1_re = re.compile(r'%[a-zA-Z]')
+exec_clean2_re = re.compile(r'%%')
+encoding = None
+locale_str = None
+
+def find_icon(entry):
+ icon = entry.getIcon()
+ if icon and with_theme_paths:
+ icon = xdg.IconTheme.getIconPath(icon, icon_size) or icon
+ return icon
+
+def process_menu(menu):
+ for entry in menu.getEntries():
+ if isinstance(entry, xdg.Menu.Menu):
+ name = entry.getName() or entry.DesktopFileID
+ icon = find_icon(entry) or default_folder_icon
+
+ if entire_menu:
+ print ("menu \"%s\" \"%s\" {" % (name, icon)).encode(encoding)
+ process_menu(entry)
+ print "}".encode(encoding)
+ else:
+ print (("menuprog \"%s\" \"%s\" %s" % (name, icon, sys.argv[0])) +
+ (" --root-folder \"%s\"" % entry.getPath(org=True)) +
+ (" --terminal \"%s\"" % terminal) +
+ (" --default-folder-icon \"%s\"" % default_folder_icon) +
+ (" --default-entry-icon \"%s\"" % default_entry_icon) +
+ (" --theme \"%s\"" % xdg.Config.icon_theme) +
+ (" --icon-size \"%d\"" % icon_size) +
+ (with_theme_paths and " --with-theme-paths" or "")).encode(encoding),
+ if locale_str:
+ print (" --locale \"%s\"" % locale_str).encode(encoding),
+ print
+ elif isinstance(entry, xdg.Menu.MenuEntry):
+ de = entry.DesktopEntry
+ name = de.getName() or entry.DesktopFileID
+ icon = find_icon(de) or default_entry_icon
+ execute = exec_clean2_re.sub('%', exec_clean1_re.sub('', de.getExec()))
+ if de.getTerminal(): execute = terminal % execute
+ print ("prog \"%s\" \"%s\" %s" % (name, icon, execute)).encode(encoding)
+
+try: opts, args = getopt.getopt(sys.argv[1:], "",
+ ("help", "version", "locale=",
+ "root-folder=", "terminal=", "default-folder-icon=",
+ "default-entry-icon=", "entire-menu", "theme=", "with-theme-paths",
+ "icon-size="))
+except getopt.GetoptError: print_usage()
+
+locale.setlocale(locale.LC_ALL, "")
+
+for o, v in opts:
+ if o == "--locale":
+ locale_str = v
+ locale.setlocale(locale.LC_ALL, locale_str)
+ if o == "--root-folder": root_folder = v
+ elif o == "--terminal": terminal = v
+ elif o == "--default-folder-icon": default_folder_icon = v
+ elif o == "--default-entry-icon": default_entry_icon = v
+ elif o == "--entire-menu" : entire_menu = True
+ elif o == "--with-theme-paths" : with_theme_paths = True
+ elif o == "--icon-size": icon_size = int(v)
+ elif o == "--theme" : xdg.Config.setIconTheme(v)
+ elif o in ("-h", "-?", "--help"): print_usage(0)
+ elif o in ("-v", "--version"): print_version()
+
+encoding = locale.getlocale()[1] or 'UTF-8'
+menu = xdg.Menu.parse()
+if root_folder: menu = menu.getMenu(root_folder)
+process_menu(menu)