summaryrefslogtreecommitdiff
path: root/x11-wm/i3/i3-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /x11-wm/i3/i3-9999.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'x11-wm/i3/i3-9999.ebuild')
-rw-r--r--x11-wm/i3/i3-9999.ebuild91
1 files changed, 54 insertions, 37 deletions
diff --git a/x11-wm/i3/i3-9999.ebuild b/x11-wm/i3/i3-9999.ebuild
index f87cfbc00631..e644fcb77f54 100644
--- a/x11-wm/i3/i3-9999.ebuild
+++ b/x11-wm/i3/i3-9999.ebuild
@@ -1,24 +1,30 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit autotools git-r3
+inherit meson optfeature virtualx
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+fi
DESCRIPTION="An improved dynamic tiling window manager"
HOMEPAGE="https://i3wm.org/"
-SRC_URI=""
-EGIT_REPO_URI="https://github.com/i3/i3"
-EGIT_BRANCH="next"
+if [[ "${PV}" = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/i3/i3"
+ EGIT_BRANCH="next"
+else
+ SRC_URI="https://i3wm.org/downloads/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
LICENSE="BSD"
SLOT="0"
-KEYWORDS=""
-IUSE="doc"
+IUSE="doc test"
-CDEPEND="dev-libs/libev
+COMMON_DEPEND="dev-libs/libev
dev-libs/libpcre
- >=dev-libs/yajl-2.0.3
+ dev-libs/yajl
x11-libs/libxcb[xkb]
x11-libs/libxkbcommon[X]
x11-libs/startup-notification
@@ -28,15 +34,31 @@ CDEPEND="dev-libs/libev
x11-libs/xcb-util-wm
x11-libs/xcb-util-xrm
x11-misc/xkeyboard-config
- >=x11-libs/cairo-1.14.4[X,xcb(+)]
- >=x11-libs/pango-1.30.0[X]"
-DEPEND="${CDEPEND}
- doc? ( app-text/asciidoc app-text/xmlto dev-lang/perl )
- virtual/pkgconfig"
-RDEPEND="${CDEPEND}
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/pango[X]"
+DEPEND="${COMMON_DEPEND}
+ test? (
+ dev-perl/AnyEvent
+ dev-perl/X11-XCB
+ dev-perl/Inline
+ dev-perl/Inline-C
+ dev-perl/IPC-Run
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/local-lib
+ virtual/perl-Test-Simple
+ x11-base/xorg-server[xephyr]
+ x11-misc/xvfb-run
+ )
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+RDEPEND="${COMMON_DEPEND}
dev-lang/perl
dev-perl/AnyEvent-I3
dev-perl/JSON-XS"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
@@ -45,11 +67,6 @@ PATCHES=(
src_prepare() {
default
- if ! use doc ; then
- sed -e '/AC_PATH_PROG(\[PATH_ASCIIDOC/d' -i configure.ac || die
- fi
- eautoreconf
-
cat <<- EOF > "${T}"/i3wm
#!/bin/sh
exec /usr/bin/i3
@@ -57,31 +74,31 @@ src_prepare() {
}
src_configure() {
- local myeconfargs=( --enable-debug=no ) # otherwise injects -O0 -g
- econf "${myeconfargs[@]}"
-}
+ local emesonargs=(
+ -Ddocdir="/usr/share/doc/${PF}"
+ $(meson_use doc docs)
+ $(meson_use doc mans)
+ )
-src_compile() {
- emake -C "${CBUILD}"
+ meson_src_configure
}
src_install() {
- emake -C "${CBUILD}" DESTDIR="${D}" install
- einstalldocs
+ meson_src_install
exeinto /etc/X11/Sessions
doexe "${T}"/i3wm
}
-pkg_postinst() {
+src_test() {
+ virtx meson_src_test
+}
- # Only show the elog information on a new install
- if [[ ! ${REPLACING_VERSIONS} ]]; then
- elog "There are several packages that you may find useful with ${PN} and"
- elog "their usage is suggested by the upstream maintainers, namely:"
- elog " x11-misc/dmenu"
- elog " x11-misc/i3status"
- elog " x11-misc/i3lock"
- elog "Please refer to their description for additional info."
- fi
+pkg_postinst() {
+ elog "There are several packages that you may find useful with i3 and"
+ elog "their usage is suggested by the upstream maintainers."
+ elog "Uninstalled optional dependencies:"
+ optfeature "Application launcher" x11-misc/dmenu
+ optfeature "Simple screen locker" x11-misc/i3lock
+ optfeature "Status bar generator" x11-misc/i3status
}