summaryrefslogtreecommitdiff
path: root/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'x11-wm/herbstluftwm/herbstluftwm-9999.ebuild')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-9999.ebuild33
1 files changed, 12 insertions, 21 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
index 30dd0c6dd266..4ebb6b1f0ad3 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-9999.ebuild
@@ -2,47 +2,42 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit toolchain-funcs cmake-utils
-
-if [[ ${PV} == 9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
- BDEPEND="app-text/asciidoc"
-else
- SRC_URI="https://herbstluftwm.org/tarballs/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- BDEPEND=""
-fi
+inherit git-r3 toolchain-funcs cmake-utils
DESCRIPTION="A manual tiling window manager for X"
HOMEPAGE="https://herbstluftwm.org/"
+EGIT_REPO_URI="https://github.com/herbstluftwm/herbstluftwm"
LICENSE="BSD-2"
SLOT="0"
-IUSE="examples xinerama zsh-completion"
+IUSE="doc examples"
DEPEND="
x11-libs/libX11
x11-libs/libXext
- xinerama? ( x11-libs/libXinerama )
+ x11-libs/libXinerama
+ x11-libs/libXrandr
"
RDEPEND="
${DEPEND}
app-shells/bash
- zsh-completion? ( app-shells/zsh )
"
-BDEPEND+="
+BDEPEND="
virtual/pkgconfig
+ doc? ( app-text/asciidoc )
"
-src_configure() {
+src_prepare() {
sed -i \
-e '/^install.*LICENSEDIR/d' \
-e '/set(DOCDIR / s#.*#set(DOCDIR ${CMAKE_INSTALL_DOCDIR})#' \
CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+src_configure() {
mycmakeargs=(
- -DWITH_XINERAMA=$(usex xinerama)
+ -DWITH_DOCUMENTATION=$(usex doc)
)
cmake-utils_src_configure
@@ -54,8 +49,4 @@ src_install() {
if ! use examples; then
rm -r "${ED}"/usr/share/doc/${PF}/examples || die
fi
-
- if ! use zsh-completion; then
- rm -r "${ED}"/usr/share/zsh || die
- fi
}