summaryrefslogtreecommitdiff
path: root/x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-04 02:14:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-04 02:14:42 +0100
commitba32ac7204934e0c69e1cc7529edce6efdbeb265 (patch)
tree79dbf15bc5803a13e0c015970a4df6e506d14205 /x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild
parent56ef021c58088c79bc71257eb348ff6decc47607 (diff)
gentoo auto-resync : 04:04:2024 - 02:14:41
Diffstat (limited to 'x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild')
-rw-r--r--x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild b/x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild
index 83a22e20d0e4..ceda002ab268 100644
--- a/x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild
+++ b/x11-wm/herbstluftwm/herbstluftwm-0.9.5-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{9..12} )
DISTUTILS_USE_PEP517=setuptools
DISTUTILS_OPTIONAL=1
@@ -24,7 +24,10 @@ LICENSE="BSD-2"
SLOT="0"
IUSE="+doc python test"
RESTRICT="!test? ( test )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+REQUIRED_USE="
+ python? ( ${PYTHON_REQUIRED_USE} )
+ test? ( python )
+"
COMMON_DEPEND="
x11-libs/libX11
@@ -137,11 +140,5 @@ src_test() {
ln -s "${BUILD_DIR}/herbstclient" || die "Could not symlink herbstclient"
ln -s "${BUILD_DIR}/herbstluftwm" || die "Could not symlink herbstluftwm"
- pushd python > /dev/null || die
- distutils_install_for_testing
- popd > /dev/null || die
-
- # Ensure PYTHONPATH is exported, see https://bugs.gentoo.org/801658.
- export PYTHONPATH
- python_test
+ distutils-r1_src_test
}