summaryrefslogtreecommitdiff
path: root/x11-wm/dwm/dwm-6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-08 01:28:43 +0100
commitad75ca50360f9590325f0f709c091832b70eab1d (patch)
tree8a0b109f05da2a3728e461abf6e31347c2e8b0b2 /x11-wm/dwm/dwm-6.4.ebuild
parent7b5e4e1f63da7fb63fba5f1a9fc41866c8ae5b2f (diff)
gentoo auto-resync : 08:10:2022 - 01:28:43
Diffstat (limited to 'x11-wm/dwm/dwm-6.4.ebuild')
-rw-r--r--x11-wm/dwm/dwm-6.4.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/x11-wm/dwm/dwm-6.4.ebuild b/x11-wm/dwm/dwm-6.4.ebuild
new file mode 100644
index 000000000000..4553c04b8640
--- /dev/null
+++ b/x11-wm/dwm/dwm-6.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="https://dwm.suckless.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.suckless.org/dwm"
+else
+ SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="xinerama"
+
+RDEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ >=x11-libs/libXft-2.3.5
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ xinerama? ( x11-base/xorg-proto )
+"
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e "s/ -Os / /" \
+ -e "/^\(LDFLAGS\|CFLAGS\|CPPFLAGS\)/{s| = | += |g;s|-s ||g}" \
+ -e "/^X11LIB/{s:/usr/X11R6/lib:/usr/$(get_libdir)/X11:}" \
+ -e '/^X11INC/{s:/usr/X11R6/include:/usr/include/X11:}' \
+ config.mk || die
+
+ restore_config config.h
+}
+
+src_compile() {
+ if use xinerama; then
+ emake CC="$(tc-getCC)" dwm
+ else
+ emake CC="$(tc-getCC)" XINERAMAFLAGS="" XINERAMALIBS="" dwm
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session2 dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}