summaryrefslogtreecommitdiff
path: root/x11-wm/cwm/cwm-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/cwm/cwm-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/cwm/cwm-9999.ebuild')
-rw-r--r--x11-wm/cwm/cwm-9999.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-wm/cwm/cwm-9999.ebuild b/x11-wm/cwm/cwm-9999.ebuild
new file mode 100644
index 000000000000..9362010d5669
--- /dev/null
+++ b/x11-wm/cwm/cwm-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs git-2
+
+DESCRIPTION="OpenBSD fork of calmwm, a clean and lightweight window manager"
+HOMEPAGE="http://www.openbsd.org/cgi-bin/cvsweb/xenocara/app/cwm/
+ https://github.com/chneukirchen/cwm"
+EGIT_BRANCH=linux
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS=""
+IUSE="vanilla"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/bison"
+
+pkg_setup() {
+ if use vanilla ; then
+ EGIT_REPO_URI="https://github.com/chneukirchen/cwm.git"
+ else
+ EGIT_REPO_URI="https://github.com/xmw/cwm.git"
+ fi
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -D_GNU_SOURCE" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README
+ make_session_desktop ${PN} ${PN}
+}