summaryrefslogtreecommitdiff
path: root/x11-wm/ctwm/ctwm-4.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /x11-wm/ctwm/ctwm-4.0.3.ebuild
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'x11-wm/ctwm/ctwm-4.0.3.ebuild')
-rw-r--r--x11-wm/ctwm/ctwm-4.0.3.ebuild33
1 files changed, 26 insertions, 7 deletions
diff --git a/x11-wm/ctwm/ctwm-4.0.3.ebuild b/x11-wm/ctwm/ctwm-4.0.3.ebuild
index 4cf2574b36c4..7c24c6682a8f 100644
--- a/x11-wm/ctwm/ctwm-4.0.3.ebuild
+++ b/x11-wm/ctwm/ctwm-4.0.3.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake
+
+inherit cmake flag-o-matic virtualx
DESCRIPTION="A clean, light window manager"
HOMEPAGE="https://ctwm.org/"
@@ -11,6 +12,8 @@ SRC_URI="https://ctwm.org/dist/${P}.tar.xz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="jpeg rplay test xpm"
+RESTRICT="!test? ( test )"
RDEPEND="
x11-libs/libICE
@@ -18,18 +21,21 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXext
x11-libs/libXmu
- x11-libs/libXpm
x11-libs/libXt
+ jpeg? ( virtual/jpeg )
+ rplay? ( media-sound/rplay )
+ xpm? ( x11-libs/libXpm )
"
DEPEND="
${RDEPEND}
app-arch/xz-utils
- app-text/rman
- virtual/jpeg
x11-base/xorg-proto
"
src_prepare() {
+ # Bug 715904, sigjmp_buf is guarded by GNU_SOURCE
+ use elibc_musl && append-cflags -D_GNU_SOURCE
+
cmake_src_prepare
# implicit 'isspace'
@@ -37,10 +43,23 @@ src_prepare() {
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DNOMANCOMPRESS=yes
- -DDOCDIR=/usr/share/doc/${PF}
+ -DDOCDIR="${EPREFIX}"/usr/share/doc/${PF}
+ -DUSE_JPEG=$(usex jpeg ON OFF)
+ -DUSE_RPLAY=$(usex rplay ON OFF)
+ -DUSE_XPM=$(usex xpm ON OFF)
)
cmake_src_configure
}
+
+src_compile() {
+ # Bug 701656, test_bins target needs to be compiled
+ # to satisfy the 't_efp' test
+ cmake_src_compile all $(usex test test_bins '')
+}
+
+src_test() {
+ virtx cmake_src_test
+}