summaryrefslogtreecommitdiff
path: root/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/aewm++/aewm++-1.1.5-r2.ebuild')
-rw-r--r--x11-wm/aewm++/aewm++-1.1.5-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild b/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
new file mode 100644
index 000000000000..843c906b41a9
--- /dev/null
+++ b/x11-wm/aewm++/aewm++-1.1.5-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A window manager with more modern features than aewm"
+HOMEPAGE="https://github.com/frankhale/aewmpp"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ emake CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc ChangeLog README
+}