summaryrefslogtreecommitdiff
path: root/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild')
-rw-r--r--x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild38
1 files changed, 16 insertions, 22 deletions
diff --git a/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild b/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
index 68a7e5ba3b2d..733a3a198bd7 100644
--- a/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
+++ b/x11-themes/wm-icons/wm-icons-0.4.0_pre1-r1.ebuild
@@ -1,52 +1,46 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-inherit autotools
+EAPI=6
-DESCRIPTION="A Large Assortment of Beutiful Themed Icons, Created with FVWM in mind"
+inherit autotools
+DESCRIPTION="A Large Assortment of Beautiful Themed Icons, Created with FVWM in mind"
HOMEPAGE="http://wm-icons.sourceforge.net/"
SRC_URI="mirror://gentoo/wm-icons-${PV}-cvs-01092003.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc ppc64 x86"
-
IUSE=""
+
RDEPEND="virtual/awk dev-lang/perl"
S=${WORKDIR}/wm-icons
-src_unpack() {
- unpack ${A}
-
- sed -i 's#$(bindir)/wm-icons-config#true#g' "${S}"/Makefile.am
- # duplication of bin/Makefile in configure.in #91764
- sed -i '132s/bin\/Makefile//' "${S}"/configure.in
- # non-portable comment bombs automake.
- sed -i 's/\t#/#/' "${S}"/Makefile.am
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.0-build.patch
+)
- cd "${S}"
+src_prepare() {
+ default
eautoreconf
}
-src_compile() {
- econf --enable-all-sets --enable-icondir=/usr/share/icons/wm-icons || die "econf failed"
- emake || die "emake failed"
+src_configure() {
+ econf --enable-icondir="${EPREFIX}"/usr/share/icons/wm-icons
}
src_install() {
# strange makefile...
- einstall icondir="${D}/usr/share/icons/wm-icons" DESTDIR="${D}" || die
+ emake icondir="${ED%/}/usr/share/icons/wm-icons" DESTDIR="${D}" install
- dodir /usr/bin
- mv "${D}"/"${D}"/usr/bin/wm-icons-config "${D}"/usr/bin/wm-icons-config
rm -rf "${D}"/var
einfo "Setting default aliases..."
- "${D}"/usr/bin/wm-icons-config --user-dir="${D}/usr/share/icons/wm-icons" --defaults
+ "${ED%/}/usr/bin/wm-icons-config" --force --user-dir="${ED%/}/usr/share/icons/wm-icons" --defaults || die
- dodoc AUTHORS ChangeLog NEWS README
+ einstalldocs
}
pkg_postinst() {